PDA

View Full Version : OpenGl games do not work



Some_Guy
03-06-2011, 11:46 PM
As title says, openGL based games such as spacechem or frozen synapse do not run or run very slowly. My PC is pretty good spec with an ATI HD4770 graphics dard, 4gig ram, 2.2ghyz dul;e core CPU ect.

please give any sugestions/fixes.

Simon
04-06-2011, 12:06 AM
Which opengl games in particular?

I would reinstall your drivers.

if its an early opengl game check opengl.dll / openegl3d.dll is in the game folder

Some_Guy
04-06-2011, 12:08 AM
It is with every OpenGL game i have, i have tried installing the drivers many times with no luck, problem started after upgrading to my current card from an olf navidia 7800gt

Simon
04-06-2011, 12:10 AM
did you reinstall windows? Its probably best after a major hardware change.

Anyway it sounds like you have some crap left over from nvidia. Run driversweeper or something similar to make sure all the nividia stuff is removed. Might as well remove all the ati stuff as well and start a fresh.

Should sort it

dancanman
04-06-2011, 03:31 AM
did you reinstall windows? Its probably best after a major hardware change.
True, but just upgrading the video card shouldn't require a re-install of windows (what version are you running btw? 7?). Nvidia drivers should show up in add/remove programs, or you can use ccleaner. Not sure if this helps, but one GL game I used to have really didn't like to run when high reflection quality was used with ati cards.

Bad Sector
04-06-2011, 04:35 AM
Well, upgrading from an nVidia to an nVidia (or AMD to AMD) card shouldn't need a format, but most of the time when you change from nVidia to AMD or vice versa it is recommended to do a format.

The Add/Remove programs and CCleaner do not help much there since we're talking about a driver that affects vital parts of the OS.

Lulz3r
05-06-2011, 05:35 PM
Before deciding to format, a less drastic and usually effective measure is to use Driver Sweeper (http://www.guru3d.com/category/driversweeper/).

For maximum effect, uninstall drivers from Add/Remove programs, restart in safe mode, run driver sweeper, in your case remove both Nvidia and AMD/ATI driver leftovers, restart in normal mode, install the latest drivers for your current GPU.

mashakos
06-06-2011, 11:05 PM
Formatting is not normal, this is a drastic measure and actually degrades platter-based hard drives over time.

I've found that with ATI drivers, hunting down corrupted registry entries does the trick.
Here's a situation I came across with my old ati 5870 that i solved this way. (http://hardforum.com/showthread.php?p=1035627911)

To the OP: Your PC is defaulting to the standard Microsoft opengl32.dll library which has no hardware acceleration support. Find out which registry entries relate to the ATI opengl driver and fix them using the method I described in the link.

pakoito
06-06-2011, 11:21 PM
It may sound biased and cruel but next time do yourself a favor and buy nVidia.

Lulz3r
12-06-2011, 11:36 PM
Actually, it just sounds smug, ill-informed, tech illiterate and all in all, retarded.

pakoito
13-06-2011, 12:27 AM
Actually, it just sounds smug, ill-informed, tech illiterate and all in all, retarded.Well I speak from experience, ATI rides the failboat most of the time in Linux and OpenGL stuff compared to nVidia. Now if you want to be a douchebag about it, I don't care.

Dirtbox
26-06-2011, 10:02 AM
Hello, yes you might need to do a little reinstalling of windows, but nothing too harsh. Try a startup repair like so (http://windows.microsoft.com/en-US/windows7/products/features/startup-repair).

You should probably make sure you've completely wiped out the nvidia drivers and have another look before doing so though.

edit: It's nothing to do with ATI btw. On this occasion it's nvidia that's causing the problem.