Results 1 to 9 of 9
  1. #1
    Network Hub FunnyB's Avatar
    Join Date
    Aug 2011
    Location
    Sweden
    Posts
    233

    Problems showing video, possible hard drive issue?

    Hi!
    I recently switched motherboard due to the old one dying on me. My system is set up with one system disk (with all software on it) and a storage disk for storage (movies, tv series, music etc).

    I noticed that whenever I started a video file from my storage disk, the video player would stall after a random amount of seconds (from 10 seconds to 2 minutes). This happens regardless of what video player I use. When using Media Player Classic (and XBMC) I can see that the video (or audio) buffer runs out just before the video freezes.

    I never had this problem before I switched motherboards.

    If I move a video file from the storage drive to the system drive, and watch it from there, everything works perfectly.
    Maybe the motherboard damaged the drive somehow when it died?

    I've run CrystalDiskInfo to check the S.M.A.R.T values on the drive, and the test turns out OK.

    Is this a sign of the disk dying? Both harddrives are at least 5 years old. Should I get a replacement drive as soon as possible to avoid total disk failure on my storage disk?

  2. #2
    Secondary Hivemind Nexus Kelron's Avatar
    Join Date
    Jun 2011
    Posts
    2,010
    Check cables, try a different SATA cable and a different SATA port on the motherboard. It's also worth updating your video codecs when you have playback problems, though from your description you're probably right that the drive is the issue.

  3. #3
    Lesser Hivemind Node Bobtree's Avatar
    Join Date
    Sep 2011
    Posts
    575
    Does the video continue several seconds after it freezes? If so you might check the sleep time set for HDDs in your power settings. Perhaps your system disk never spins down, but the storage disk is being shut off between reads.

  4. #4
    Network Hub FunnyB's Avatar
    Join Date
    Aug 2011
    Location
    Sweden
    Posts
    233
    In programs like Media Player Classic or XBMC, where you can see the buffer status, you can see how the buffer starts to drop towards zero. When the buffer reaches zero, the video and audio freezes completely. If you wait a few minutes, the video might resume and play a few more seconds before freezing again.

    I have switched off Hard drive sleeping in the Power options, but this does not seem to have any effect.

    I have now verified that it is possible to watch video files from the system disk, from a USB memorystick, and from a network connected disk. The only time I have problems, is when I watch video files from my storage disk. This furthers my suspicion that the disk is starting to become corrupt and that it isn't a video codec issue.
    Listening to music from the drive seems to work OK, and copying and deleting files from the drive is not an issue. Yet at least.
    However, I noticed that a few times, it took a little time to load the contents of a folder when using explorer. This also makes be believe that the problem has to do with reading from the drive.

    It seems like I will have to buy a new hard drive to replace it. Before doing that I will use the drive sparingly, hoping that it doesn't completely die on me.

  5. #5
    Secondary Hivemind Nexus Kelron's Avatar
    Join Date
    Jun 2011
    Posts
    2,010
    Use a program like the free version of HD Tune to benchmark the drive and see if there's general speed issues with it. My 7200rpm SATA 2 drives start at around 90-130 MB/s read speed for comparison. It's normal for the transfer speed to slow as the test goes on, and there may be large spikes if other things are accessing your hard drive at the same time (best to run the benchmark with nothing else running).

    Edit: If you haven't done so already, backup anything super important onto another drive as soon as you can, just in case.

  6. #6
    Network Hub FunnyB's Avatar
    Join Date
    Aug 2011
    Location
    Sweden
    Posts
    233
    These are the results:



    The transfer rate is really dipping at the end....

  7. #7
    Secondary Hivemind Nexus Kelron's Avatar
    Join Date
    Jun 2011
    Posts
    2,010
    It's normal for the rate to drop during the benchmark. That's quite slow but I'm not sure it's abnormal for the age of the drive, or slow enough to cause problems loading videos. Not that it necessarily rules out drive failure - I don't know that much about the internal workings of a hard drive but intermittent mechanical problems might be possible.

    Have you run CHKDSK on it? I'm not convinced it ever really helps, but worth a try.

  8. #8
    Secondary Hivemind Nexus
    Join Date
    Jun 2011
    Posts
    4,876
    Get the SMART stats for the drive - you're looking for 'Reallocated Sectors' or 'CRC Errors' - the former is a sign of an HDD which is dying - the latter usually points to interface issues (plugs and cables)

  9. #9
    Network Hub FunnyB's Avatar
    Join Date
    Aug 2011
    Location
    Sweden
    Posts
    233
    Here are the SMART stats:

    As you can see, everything seems alright.

    Here's what I can see happens in Windows Resource Monitor when I am just browsing the file explorer on the disk, and I run into a sudden freeze.

    The Active time meter spikes and the drive stalls.


    After a random amount of time, the meter goes down, but the operation I tried to do (open a folder) is not carried out. I remain in the same folder that I began in. But opening the folder after works OK.


    And here you can see how Media Player Classic has emptied it's buffers when playing a video file, and how the Active Time meter spikes again.


    I tried switching both SATA cable and SATA port, but it made no difference.
    I have now made backup copies of everything important on the drive, and I have pretty much determined that the drive has to be replaced.

    Thank you all for your help!
    Final thoughts? Comments?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •