Results 1 to 17 of 17
  1. #1
    Secondary Hivemind Nexus Heliocentric's Avatar
    Join Date
    Jun 2011
    Posts
    10,268

    Why does XCOM make my PC wheeze like an asthmatic hoover.

    I can't make sense of it, some games often less demanding ones make my PC freak out... It's probably something to do with VSYNC not activating properly but does anyone have any tips?
    I'm failing to writing a blog, specifically about playing games the wrong way
    http://playingitwrong.wordpress.com/

  2. #2
    Activated Node Xzi's Avatar
    Join Date
    Aug 2014
    Location
    Colorado
    Posts
    77
    Honestly couldn't tell you. I've ran it maxed out on both an AMD and Intel/Nvidia system now with no problems. Smooth as butter.
    ~

  3. #3
    Secondary Hivemind Nexus Heliocentric's Avatar
    Join Date
    Jun 2011
    Posts
    10,268
    Quote Originally Posted by Xzi View Post
    Honestly couldn't tell you. I've ran it maxed out on both an AMD and Intel/Nvidia system now with no problems. Smooth as butter.
    Sorry, I should be clear, it runs fine, but it makes me PC really loud and all the fans whizz, even though other games, say Black Flag of Skyrim don't do the same.
    I'm failing to writing a blog, specifically about playing games the wrong way
    http://playingitwrong.wordpress.com/

  4. #4
    Activated Node Xzi's Avatar
    Join Date
    Aug 2014
    Location
    Colorado
    Posts
    77
    Quote Originally Posted by Heliocentric View Post
    Sorry, I should be clear, it runs fine, but it makes me PC really loud and all the fans whizz, even though other games, say Black Flag of Skyrim don't do the same.
    Odd. Yeah, I think I read about some others having the same issue, but that was way back on release. The load shouldn't be such that it's overheating anything, so fans shouldn't need to work that hard. Maybe something about the way the game sends instructions to the CPU. Again, just shooting in the dark here.
    ~

  5. #5
    Secondary Hivemind Nexus rockman29's Avatar
    Join Date
    Jul 2013
    Posts
    1,974
    I guess it's making the GPU work too hard for something.

    I think a lot of people had the same problem when StarCraft 2 first came out, I think in the in-engine cutscenes on the Hyperion and stuff there was no frame limiter so the game was trying to run at unholy FPS levels or something something.

    So maybe something similar.... maybe try forcing vsync in the GPU panel?

  6. #6
    Secondary Hivemind Nexus
    Join Date
    May 2012
    Posts
    1,614
    Yep, possibly trying to render at 300fps.
    It is a technical difference, but's there none the less.

  7. #7
    Lesser Hivemind Node
    Join Date
    Aug 2013
    Location
    Germany
    Posts
    569
    Quote Originally Posted by rockman29 View Post
    I guess it's making the GPU work too hard for something.

    I think a lot of people had the same problem when StarCraft 2 first came out, I think in the in-engine cutscenes on the Hyperion and stuff there was no frame limiter so the game was trying to run at unholy FPS levels or something something.

    So maybe something similar.... maybe try forcing vsync in the GPU panel?
    Sounds likely - too high framerate in mostly idle scenes. It's (coil) noise because of inferior components and/or processing.
    People are currently complaining about this a lot with the latest 9X0 cards from Nvidia. Not that it didn't exist before across all brands, but it's getting worse.

    Your best bet is to use Vsync or a frame limiter to limit it to your monitors refresh rate (no use going higher anyway - you can't see it), because it gets worse the higher your framerate. Afterburner and similar tools can do that for you. Unfortunately they all need admin rights to autostart, so you might have to start them manually after every boot (or at least type your password every time).
    Bad practices often become a trend if not dealt with.

  8. #8
    Secondary Hivemind Nexus
    Join Date
    Jan 2013
    Posts
    2,609
    Quote Originally Posted by DanMan View Post
    Your best bet is to use Vsync or a frame limiter to limit it to your monitors refresh rate (no use going higher anyway - you can't see it),
    Correct me if I'm wrong, but this is wrong, no? Unless you are using something like Gsync the monitor refresh and frame rendering aren't going to be perfectly in step, so frames are going to get delayed or missed or whatever. I dunno, I'm not a professional monitor technician. So ideally you want more fps than refresh rate (not that it matters at all in a game like XCOM).

  9. #9
    Lesser Hivemind Node
    Join Date
    Aug 2013
    Location
    Germany
    Posts
    569
    Quote Originally Posted by Rizlar View Post
    Correct me if I'm wrong, but this is wrong, no? Unless you are using something like Gsync the monitor refresh and frame rendering aren't going to be perfectly in step, so frames are going to get delayed or missed or whatever. I dunno, I'm not a professional monitor technician. So ideally you want more fps than refresh rate (not that it matters at all in a game like XCOM).
    Without VSync, you're right. Simply limiting the framerate will not get rid of tearing (but it's less noticeable than at way lower framerates than your monitor's refresh rate) - that's what VSync is for.
    The limiter is just a catch-all thing. Even in games where VSync is available, it can happen that during cutscene movies the framerate explodes for whatever reason. That's when the limiter is useful. It also keeps your temperatures and wattage low.


    Personally, I set my limiter to 62fps, just to be sure it's actually rendering at least 60fps for VSync, which I'm usually using, too. MSI Afterburner, Palit ThunderMaster and others will let you do that for NV cards.
    Last edited by DanMan; 15-11-2014 at 03:50 PM.
    Bad practices often become a trend if not dealt with.

  10. #10
    Secondary Hivemind Nexus Heliocentric's Avatar
    Join Date
    Jun 2011
    Posts
    10,268
    When I played Natural Selection in clans I often found rendering about locked 180fps (on a 90hz crt) gave me the smoothest experience, but xcom? You could lock it at 30 and it would be okay.
    I'm failing to writing a blog, specifically about playing games the wrong way
    http://playingitwrong.wordpress.com/

  11. #11
    Lesser Hivemind Node
    Join Date
    Aug 2013
    Location
    Germany
    Posts
    569
    Quote Originally Posted by Heliocentric View Post
    When I played Natural Selection in clans I often found rendering about locked 180fps (on a 90hz crt) gave me the smoothest experience, but xcom? You could lock it at 30 and it would be okay.
    I guess, but if your system can handle it, I'd always go for whatever your monitor's refresh rate is.
    Bad practices often become a trend if not dealt with.

  12. #12
    Secondary Hivemind Nexus Grizzly's Avatar
    Join Date
    Jun 2011
    Location
    The Bishopric of Utrecht
    Posts
    2,170
    If you use an AMD card, try RadeonPro, it has a setting to lock the FPS of any game to the monitor's refresh rate. Works wonders for overheating.


  13. #13
    Secondary Hivemind Nexus sabrage's Avatar
    Join Date
    Jun 2011
    Location
    GMT-7
    Posts
    3,375
    Quote Originally Posted by DanMan View Post
    Sounds likely - too high framerate in mostly idle scenes. It's (coil) noise because of inferior components and/or processing.
    People are currently complaining about this a lot with the latest 9X0 cards from Nvidia. Not that it didn't exist before across all brands, but it's getting worse.
    I was gonna ask, but I found it myself.

  14. #14
    Secondary Hivemind Nexus mickygor's Avatar
    Join Date
    Dec 2011
    Location
    Leicester, UK
    Posts
    1,764
    I used to really enjoy the coil whine on my GTX 280s. It made ship spinning in EVE into a musical instrument.
    Itsbastiat, Dawngate
    Bastiat, Planetside 2, Miller NC
    Therin Khatta, FFXIV, Cerberus

  15. #15
    Lesser Hivemind Node Bobtree's Avatar
    Join Date
    Sep 2011
    Posts
    612
    It's worth mentioning that your XCOM:EU and EW config files may have recently been wiped by the UE3 DST bug. Very annoying if you edited the ini files to disable startup movies, enable armor colors, etc.

    You could try enabling framerate smoothing and editing the MaxSmoothedFrameRate setting in XComEngine.ini if Vsync is not working correctly. Are you sure that's the case? I would check with FRAPS and toggle Vsync in the game and driver settings just to be sure, maybe update/reinstall drivers if necessary.

  16. #16
    Secondary Hivemind Nexus Heliocentric's Avatar
    Join Date
    Jun 2011
    Posts
    10,268
    Forcing VSync in my driver options calmed it down a great deal.
    I'm failing to writing a blog, specifically about playing games the wrong way
    http://playingitwrong.wordpress.com/

  17. #17
    Activated Node
    Join Date
    Apr 2014
    Posts
    49
    Nothing annoys me more than games that have main menus that push my GPU usage to 100% when nothing in the actual game does.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •