Results 1 to 11 of 11
  1. #1
    Network Hub
    Join Date
    Jun 2011
    Posts
    112

    Deus EX HR mouse lag problems

    Hi guys

    Recently bought this game and I'm noticing the mouse controls arn't snappy and fast. It is like theres some horrible mouse acceleration setting or something. I've gone through all the settings and can't see anything, did anyone else notice this? is there some way of fix?

    Cheers

  2. #2
    Secondary Hivemind Nexus Berzee's Avatar
    Join Date
    Jun 2011
    Posts
    2,091
    turn off vsync =)

  3. #3
    Secondary Hivemind Nexus Berzee's Avatar
    Join Date
    Jun 2011
    Posts
    2,091
    Or, if you're running it on a television screen and turning off vsync causes hilarious screen tearing, the best you can do is turn the sensitivity up to the highest settings you can stomach

  4. #4
    Network Hub
    Join Date
    Jun 2011
    Posts
    112
    Turning off V-sync makes the FPS really choppy, its not the sensitvity it is the mouse acceleration, it feels like my mouse is a god damn analog stick :( I guess this is just another consolitis attribute. Also dude I'm a pc gamer on a pc gamer forum I don't game through a TV lol!

  5. #5
    Network Hub
    Join Date
    Jun 2011
    Posts
    465
    You could perhaps try turning off Vsync in-game and forcing it through your graphics card control panle, although I'm not sure if / how well that would work.

    Mouse lag/acceleration with Vsync enabled has been a problem in most console ports I've played to various degrees. I don't know why it is, but it seems that games made for the PC don't tend to suffer these issues. I suspect it's something to do with the way input is handled relative to framerate when coding for a controller as opposed to coding for a mouse, which might be a hard thing to 'port' without re-doing a lot of code. It's very annoying though.

    Check the DX:HR forums, there might be some mods/hacks/config tweaks that can help.

  6. #6
    Network Hub MD!'s Avatar
    Join Date
    Jun 2011
    Posts
    249
    I think you're probably talking about mouse lag, rather than acceleration.*

    I was never running vsync, but still had pretty terrible input lag.

    Some people say that turning down the Maximum Pre-Rendered Frames or Flip Queue setting (for Nvidia and ATI respectively) in your video drivers helps. Personally the only thing that made a significant positive difference was lowering the resolution, presumably because it improved the framerate.

    I can only assume there's a constant input lag of <i>n</i> frames, so that the lag in milliseconds varies from intolerably awful with low FPS to pretty okay at a high framerate. So I can see why the Flip Queue thing could theoretically help. (If the problem is caused by some sort of post-processing, meaning the game is rendering, say, 4 frames in advance, that would explain why it felt horrible at 20fps and relatively decent at 60). You could also try turning off post-processing in the game options. This could help in either case, either by reducing the value of <i>n</i> or simply boosting the framerate.

    It remained noticably laggy for me, but I'm relatively fussy about these things, and it was certainly playable at the higher framerate. (Can't remember exactly what it was -- I don't think I was getting a steady 60 though, possibly significantly worse.)


    *(Acceleration just means that cursor movement depends on the speed at which you move your mouse, as well as the distance. To test for acceleration, quickly snap your mouse across the pad, then slowly move it back to its starting position. If you don't turn as far on the way back, acceleration is on. If you turn further, you're getting negative acceleration. In the case of DXHR, before you even get to the second step, you'll probably notice that when you stopped moving the mouse, the cursor kept going for a split second, because it hadn't started moving till slightly after you moved the mouse.)
    Last edited by MD!; 06-10-2011 at 12:43 AM.

  7. #7
    Network Hub
    Join Date
    Jun 2011
    Posts
    112
    Hi

    Yes it must be lag, Ive readup on various places and there doesn't seem to be a proper fix. Its just another case of "this is a console port, putup or shutup". I find it odd though that no reviews mentioned this? To be as a pc gamer the controls are ultimately what separates the pc from the console. It is annoying but I am enjoying the game, I just wish the mouse could be more snappy.

  8. #8
    Secondary Hivemind Nexus thegooseking's Avatar
    Join Date
    Jun 2011
    Location
    Three miles from the nearest bus stop
    Posts
    1,079
    I have to say, I turned off pre-rendered frames in the nvidia control panel before I played the game, and I never had any problems (apart from the fact that the mouse control in the intro where you're just walking through the lab with Megan is a lot slower than the mouse control in the rest of the game, which isn't a problem so much as it's by design, but initially fooled me into believing the mouse control was bad).

    I kind of wish I'd tried it without disabling pre-rendered frames so I could have compared them...
    "Moronic cynicism is a kind of na´vetÚ. It's na´vetÚ turned inside-out. Na´vetÚ wearing a sneer." -Momus

  9. #9
    Network Hub
    Join Date
    Jun 2011
    Posts
    112
    I'm also getting FPS dropping randomly for no reason, Im running a sandybridge i5, 8 gig ram, Geforce GTX 570. The game doesn't even look like it needs anywhere near my specs. Perhapds it's just another badly coded, badly optimised game :( Consolitis!!!

  10. #10
    Secondary Hivemind Nexus thegooseking's Avatar
    Join Date
    Jun 2011
    Location
    Three miles from the nearest bus stop
    Posts
    1,079
    Quote Originally Posted by Bilbo1981 View Post
    I'm also getting FPS dropping randomly for no reason, Im running a sandybridge i5, 8 gig ram, Geforce GTX 570. The game doesn't even look like it needs anywhere near my specs. Perhapds it's just another badly coded, badly optimised game :( Consolitis!!!
    Honestly? I'm running a Lynnfield i5, 4 gig ram and a GT 240 and I had no such problem. That's just wrong.

    (Edit: Though come to think of it, the fact that the GT240 doesn't support DX11 might have something to do with it? I'm not at my computer right now, but can you force DX9/DX10?)
    Last edited by thegooseking; 12-10-2011 at 05:00 PM.
    "Moronic cynicism is a kind of na´vetÚ. It's na´vetÚ turned inside-out. Na´vetÚ wearing a sneer." -Momus

  11. #11
    Network Hub Zyrden's Avatar
    Join Date
    Jun 2011
    Posts
    105
    I had mouse lag too at times, though it was seemingly random. Going into and out of the menu until it returned to normal worked for me. Seems weird, but eh, bugs these days can be anything I suppose.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •