Results 1 to 3 of 3
  1. #1

    Help! My audio is feedbacking

    I don't know what the hell is going on here but all of a sudden every sound my PC makes, such as the start up sounds gets stuck in an endless loop of feedback. The only way to stop it is to change from 5.1 to 2.0 channel speakers in my Creative control panel. But then it'll do it again, any system sound or anything played from media player etc - just changing the number of speakers stops the sound from playing until I make another sound.

    What the hell is going on?!

    Soundcard is an X-Fi, I've had it a long time and yesterday was fine until I booted up today and the start-up sound scared the shit out of me.

  2. #2
    Why can't I edit my post?

    Anyway, I think my X-Fi is dying. I forgot to mention that I had to uninstall and re-install the Daniel K Creative drivers: SB X-Fi Series Support Pack 2.5, after I lost the ability to record "what U hear" a few days ago, which used to work just fine.

    After posting the OP above I noticed the "listen to this device" was ticked in the Recording settings under Sounds in Control Panel, once I un-ticked this the looping feedback stopped - though that tick box wasn't a problem yesterday so something's changed. Either way I seem to be able to record "what U hear" still and the looping sounds have stopped but it'll probably go wrong again if the sound card is faulty.

  3. #3
    Secondary Hivemind Nexus somini's Avatar
    Join Date
    Jun 2011
    Location
    NEuro Troika Franchulate #3
    Posts
    3,526
    This thread logs me out! Nuke it from orbit!
    Steam(shots), Imgur, Flickr, Bak'laag, why do you forsake me?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •