Results 1 to 6 of 6
  1. #1
    Secondary Hivemind Nexus Voon's Avatar
    Join Date
    Dec 2011
    Location
    Sultanate of Johore
    Posts
    1,956

    The heck is wrong with my PC?

    Usually, my PC won't boot up when it gets infected. Most of the time, I just need to format it and wipe my hard drive clean to start over. This time, my monitor won't even detect the signal from my PC and the mouse and keyboard's not working at all. But the power's on so, most probably it's a hardware causing this problem, I think. And yes, I did reseated my RAM and the monitor's still blank. Please help?

  2. #2
    Network Hub
    Join Date
    Jun 2011
    Posts
    118
    How many beeps when you start it up? Could be your gfx card, if its not booting cause of that, then you keyboard/mouse won't work as its not even getting to that stage

  3. #3
    Secondary Hivemind Nexus Voon's Avatar
    Join Date
    Dec 2011
    Location
    Sultanate of Johore
    Posts
    1,956
    Sadly, no beeps. Just lights so, just my power supply's working. Do I have to reseat the gfx card too?

  4. #4
    Obscure Node
    Join Date
    Dec 2011
    Location
    Bolehland
    Posts
    25
    If you can get a spare graphics card, try switching it with your current one and see if it still works. If you have integrated graphics, you could also try taking out your card and using that. If the computer boots after removing the card, it's probably the card that's the problem.

    Also, have you tried running with just 1 stick of RAM at a time, and switching the stick out if it still doesn't work? The same thing you described happened to my old PC once because of bad RAM.

  5. #5
    Secondary Hivemind Nexus Voon's Avatar
    Join Date
    Dec 2011
    Location
    Sultanate of Johore
    Posts
    1,956
    so, I'll just have to take out the gfx card to see if it boots? well, it's probably the gfx or the RAM since everything's dusty inside. I'll try that. Thanks.

  6. #6
    Secondary Hivemind Nexus Voon's Avatar
    Join Date
    Dec 2011
    Location
    Sultanate of Johore
    Posts
    1,956
    Alright, the gfx card has probably crapped out on me. The fan's not moving. Probably need to buy a new one. The PC did boot however, but just for a short time before it goes blank again.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •