Results 1 to 20 of 20
  1. #1
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469

    System sluggish immediately after startup

    Hi guys. Got a weird problem. I have a fairly powerful desktop machine running Windows 7 - Core2Quad @ 266Ghz, 4GB RAM. Every time it starts up, it hangs for almost exactly the same amount of time - around 30 seconds. During this time the system is unresponsive, and I can hear a physical HDD read noise in a steady rhythm every 1 second: chug.... chug... chug... chug...

    It's a powerful PC, and almost no apps are loading in the background (dropbox and 4 autohotkey scripts) and even then, they've already loaded before this happens.

    It happens like clockwork on every single boot and it's starting to drive me batty. I have a 1GB Atom machine in the kitchen that doesn't share this problem.

    HDD is a 2TB one sort of short stroked - a 300GB partition and then a 1.7TB one for data. Steam (Which DOESN'T launch on startup) is on the 300GB along with Windows. 1.7TB partition is just music, photos etc.

  2. #2
    Lesser Hivemind Node Feldspar's Avatar
    Join Date
    Jan 2012
    Posts
    634
    Check to see if the HDD cable isn't working itself loose.

    Does it only do this on start-up or has it done it at other times?

  3. #3
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    only on startup. It's a perfect machine the rest of the time so I don't think its a cable

  4. #4
    Network Hub
    Join Date
    May 2012
    Posts
    356
    Do you hibernate your computer?

    If so sounds like its just the hard drive moving files to memory, even if you do not hibernate your computer it could still just be Windows 7 loading from disk into memory. The only other option is there is something wrong with the hard drive or its connection.

    Edit: Also being 2tb is your drive a 5200rpm?
    Last edited by byteCrunch; 26-06-2012 at 05:49 PM.

  5. #5
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    It's interesting you should say that. I used to hibernate, but that was causing issues for me where it wouldn't resume properly, so I stopped. Now it's a clean boot every time. I'm willing to accept its a HDD issue (although it's less than a year old so I'll be annoyed if it is) but I can't see how it could be a connection issue - a loose cable that remains loose for exactly 30 seconds every time I boot and then works fine?

    Loading games, copying data etc takes very little time

  6. #6
    Network Hub
    Join Date
    May 2012
    Posts
    356
    Quote Originally Posted by roryok View Post
    It's interesting you should say that. I used to hibernate, but that was causing issues for me where it wouldn't resume properly, so I stopped. Now it's a clean boot every time. I'm willing to accept its a HDD issue (although it's less than a year old so I'll be annoyed if it is) but I can't see how it could be a connection issue - a loose cable that remains loose for exactly 30 seconds every time I boot and then works fine?

    Loading games, copying data etc takes very little time
    An issue with the connection could cause read/write fails, so your hard drive is having to constantly re-read and rewrite until it succeeds which can cause slow down. Another suggestions check the fragmentation of the drive, that could impact load time on boot since Windows has to load alot of files.

  7. #7
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    ok, I don't know why I didn't check this before, but I just looked in the event log, and there's a bunch of errors that say

    The device, \Device\Harddisk0\DR0, has a bad block
    So obviously the HDD is failing after all. Sorry to waste everyone's time and thanks for the help!

  8. #8
    Network Hub
    Join Date
    May 2012
    Posts
    356
    Indeed, nothing worse then discovering your hard drive is failing, at least you caught it. The sluggish performance would have been Windows moving files out of the bad sector.

  9. #9
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    running diagnostics at the moment but I'm realising it actually is a lot slower just navigating from folder to folder. I had a weird paranoid feeling that if I upgraded from my old 8MB cache 250GB drives to a brand new 2TB drive it'd somehow give me trouble. Should have trusted my gut. SSD Time!

  10. #10
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    or maybe not. The cheapest SSD on dabs bigger than 256GB is €520! EEeeeep!

  11. #11
    Lesser Hivemind Node Feldspar's Avatar
    Join Date
    Jan 2012
    Posts
    634
    Quote Originally Posted by roryok View Post
    or maybe not. The cheapest SSD on dabs bigger than 256GB is €520! EEeeeep!
    Er, yes, you don't use an SSD for general storage, just your most used files, it's not a replacement at current prices, more of a booster.

  12. #12
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    yeah I know that, but my steam folder alone is over 200GB.

  13. #13
    Network Hub
    Join Date
    Jun 2011
    Posts
    147
    then take this as a lesson to not install your steam folder in your OS partition.

  14. #14
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    Would that not be good practice? The advantage of an SSD is a speedier transfer from storage into memory. If I keep my steam folder on a standard disk, the OS will boot like lightning off the SSD, but surely any steam games won't see an advantage?

  15. #15
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    I guess I could go for a 128GB SSD, and split my steam folder across two drives? older games / ones I'm not currently playing could go on the old HDD, and current stuff I want to play could stay on the SSD. If I do it this way, I could pick up a 128GB SSD for €100 and a 750GB Seagate Momentus for €150. That's dropping €250 on storage though. ouch.

    I clocked all my system folders without the steam folder, and it came in at 55GB, so I think leaving it at a 64GB SSD would be cutting it too fine.

    This thread is getting really off topic. Thanks again for all the help!

    PS: I ran a full disk check and the bad blocks are gone along with the issue! I'm still wary of this drive though, I'll be doing regular backups and if it goes belly up I might spring for the above setup.

  16. #16
    Network Hub
    Join Date
    Jun 2011
    Location
    Toronto, Canada
    Posts
    460
    Replace that drive ASAP! One bad sector is almost always a sign that many many more are about to occur.

    I also recommend not putting Steam on the same drive as your OS if possible. Games make your hard drive work pretty hard, as does your OS, so that's a lot of wear and tear on a single drive. Best to split them up. If I were doing it I'd buy a 128GB SSD for my OS and another 2TB HDD for my games, data, etc.

  17. #17
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    Quote Originally Posted by djbriandamage View Post
    Replace that drive ASAP!
    ....
    If I were doing it I'd buy a 128GB SSD for my OS and another 2TB HDD for my games, data, etc.
    I think I'd better replace it alright. Annoyed about that. It's barely a year old!

  18. #18
    Network Hub
    Join Date
    Jun 2011
    Posts
    147
    Quote Originally Posted by roryok View Post
    I think I'd better replace it alright. Annoyed about that. It's barely a year old!
    you're going to get it replaced under warranty, right?

  19. #19
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    Quote Originally Posted by Kamikaze-X View Post
    you're going to get it replaced under warranty, right?
    Yes. I'm still annoyed though.

  20. #20
    Network Hub roryok's Avatar
    Join Date
    Oct 2011
    Location
    IRL (IRL)
    Posts
    469
    Motherf.... the date of purchase was 6/6/2011. A day which shall live in infamy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •