Results 1 to 9 of 9
  1. #1

    Hard drive query.

    Hello,

    I bought a new PC yesterday, set it up today. I don't have a windows boot disk at the moment, so I plugged in my old hard drive from the previous computer. The computer won't boot correctly - It recognises the drive, and can get to the 'Loading windows' screen, but then a very very brief bluescreen occurs, and it goes into repair mode. It announces that it's repairing HDD files, then reboots, and the same occurs.

    Does anyone know what could be happening, why this may be?

    (Not sure if this is relevant, but I haven't installed the mobo drivers, GPU drivers, etc.)

  2. #2
    Secondary Hivemind Nexus Sakkura's Avatar
    Join Date
    Jul 2012
    Location
    Denmark
    Posts
    1,415
    So, the hard drive just has the Windows install etc. from your old computer? That's not going to work, at least not reliably. It needs to be reinstalled.

  3. #3
    That's probably my issue, then. At least I haven't broken anything :) Thanks for your prompt reply.

  4. #4
    Secondary Hivemind Nexus
    Join Date
    Jun 2011
    Posts
    5,566
    You can sometimes swap a boot disc from one PC to another and they'll work - but most of the time it will just BSOD either on startup or shortly thereafter.

    If you're deadly keen to keep your Windows installation 'as is' and you can get access to the same installation disc you used originally, you can try a 'Repair Install' which will replace all the system files with 'the right ones' for that system - it should then startup and make you dance for hours replacing drivers and other stuff - but will eventually run.

    It will never be ideal tho - you're bound to have stuff installed you don't want and other 'issues' which may or may not bite you later - your best bet is a clean install really...

  5. #5
    Secondary Hivemind Nexus President Weasel's Avatar
    Join Date
    Jun 2011
    Posts
    2,615
    Why are computers like helicopters?

    Alex Bakke makes them crash.

  6. #6
    Network Hub
    Join Date
    Aug 2012
    Posts
    177
    clean install is the best bet. grab a copy of windows and start from scratch. will save you more than money and time in the long run.

  7. #7
    Secondary Hivemind Nexus
    Join Date
    Jun 2011
    Posts
    1,646
    Pretty sure I know what is happening here.
    Your new PC has the SATA system set to "AHCI mode" - the more modern and genreally preferable mode. However you were previously running in "IDE mode" - and Windows only installs the drivers for AHCI during its own install.
    Switch over to IDE mode in the BIOS and you'll be fine in al probability (there is a way to force windows to install AHCI drivers later too)

  8. #8
    Obscure Node
    Join Date
    Jan 2013
    Posts
    15
    Don't ever do this.

    Don't take a drive from one PC and put it into another its just not good.

    Windows 7 will do a good autodetect but you will have all these files and drivers from a previous system. Ion nuke/format and re-install windows.

  9. #9
    Secondary Hivemind Nexus Sakkura's Avatar
    Join Date
    Jul 2012
    Location
    Denmark
    Posts
    1,415
    Quote Originally Posted by Komsomol View Post
    Don't ever do this.

    Don't take a drive from one PC and put it into another its just not good.
    Nothing wrong with moving a hard drive from one PC to another, as long as you're not booting from it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •