Results 1 to 17 of 17
  1. #1
    Network Hub Hunchback's Avatar
    Join Date
    Jun 2012
    Location
    Europe
    Posts
    238

    Exclamation Found a fix for the notorious video-crash-music-keeps-going bug (on NVIDIA cards)

    Hey all, i am posting this so it can get indexed in search engines and people experiencing the same problems i was might find it.

    What's this all about: I've been having problems with GW2 since beta. Back then i thought it was because the game was still in beta and not optimised for all hardware. I held on buying it till recently, to give it time to develop, get patched, and see if the community will last etc. I bought the game last week, only to find out that the crash-bug remained, after all this time, multiple versions of drivers and hardware changes and patches applied to the game. I was very put-off, since the bug is extremely annoying and can have slightly different manifestations.

    With me it was like that: the video would (seemingly) randomly freeze, with sort of green lines showing here and there on the screen. The music and sound would keep going, my keyboard and mouse would be active for about 1 or 2 seconds more, then shut down. The only way to recover was to hard-reset the system, which is -really- annoying because of the loading times.

    Note: I've experienced this exact same bug with only 1 other game, ever - Sniper Elite v2.


    I've spent a lot of time searching the net for info, i tried contacting the tech support of NCSoft, tried a lot of "solutions"... Finally i think i've found a solution to the problem, which i applied yesterday and the game has been stable since (tested it out for about 5-6 hours straight, not a single crash happened).

    Here's the info on my rig:

    OS: Win7 64bit Pro
    MB: Asus P7P55D
    CPU: i5 760 @ 2.8Ghz
    RAM: 8gb DDR3
    GPU: GeForce GTX 460

    I read some rumours that the problem is related to the GTX series of NVidia cards. I cannot confirm if it's true, since i only have mine. I can confirm that my wife's pc which is running ATI has never had the problem.


    The solution:

    In the NVIDIA Control Panel, you can set some options for individual applications. One of these options concerns power management on the GPU. By default it's on "auto", which enables the drivers to adjust the power state of the GPU according to the current/previewed load it's experiencing. Normally, games and other 3d-heavy applications keep the setting to "max performance" while they are running, but apparently, some applications have trouble with that option, which leads to switching states while running heavy loads and thus video crashes. The solution is very simple - You gotta go to the Nvidia Control Panel and set the option manually for GW2 to "max performance".

    Here's how it's done:

    Right click your desktop -> NVIDIA Control Panel -> From the tree to the left select Manage 3D Settings -> On the screen to the right select the Program Settings tab -> From the drop-down list select Guild Wars 2 (gw2.exe) (should be available in the drop-down list, if it's not click "Add" and navigate to where your gw2.exe is located) -> From the feature list on the same screen select Power Management Mode and set it to Prefer Maximum Performance -> Click Apply -> ??? -> Win

    gw2bugfix.jpg

    Note: The exact naming of the menus changes slightly with driver version changes, however the structure remains the same and the names are like 90% the same.

    As said earlier - This fixed the problem for me. It might not work for everyone, especially if you are not using an NVIDIA card, since you may not have the same option. If you do have such an option in the ATI control panel, it might be worth checking it out though.


    Here's a list of things that DO NOT work:

    Various modifications to the Video options in GW2 (including shadows, AA, reflections)
    Various modifications to the Sound options in GW2 (Quality, stability, etc)
    Closing all other un-needed software on the PC
    Setting the gw2.exe process to high-priority
    Playing the game in a window or borderless window
    Updating video drivers
    Running the game as administrator
    Smashing your face in the keyboard

    Note: I read that for some people, setting the video options to low, removing shadows, AA and others helps in the way of extending the time before the game would crash. It does not resolve the problem though, just delays it. Also, in my opinion setting a game you could run on high to low just so it doesn't crash every 15 minutes (or even at all for that matter) is NOT a solution anyway.

    K so there it is, hope it helps people who have been experiencing this annoying bug.
    --
    -- V. Don Quixote. Tyler Durden. Donnie Darko. Martin Sillenas. Maynard. Rorschach. You. Me.

  2. #2
    Secondary Hivemind Nexus Squiz's Avatar
    Join Date
    Jun 2011
    Location
    Arcadia
    Posts
    4,133
    Glad you could sort out your issues with the game crashes and graphics problem. Very nice of you to post this here.

  3. #3
    Secondary Hivemind Nexus Screwie's Avatar
    Join Date
    Jun 2011
    Location
    Swansea
    Posts
    3,081
    I used to get a lot of CTD during the GW2 beta, the proposed fix then was to underclock my GTX570 card by about 10-20%. That worked a treat, but I might give this a try sometime too and see if it would also fix my issues (would be nice to get that 10-20% back!).

    What nVidia driver version are you using?

  4. #4
    Network Hub Hunchback's Avatar
    Join Date
    Jun 2012
    Location
    Europe
    Posts
    238
    Currently, the latest beta drivers (6.9.840.0)

    As i stated earlier, downclocking, turning off options etc is not a real solution for me. I just wish devs would bother fixing stuff like that, but oh well.
    --
    -- V. Don Quixote. Tyler Durden. Donnie Darko. Martin Sillenas. Maynard. Rorschach. You. Me.

  5. #5
    Lesser Hivemind Node Feldspar's Avatar
    Join Date
    Jan 2012
    Posts
    634
    That's odd, my system is pretty similar to yours, with a GTX460, but I've never suffered this problem. Admittedly my drivers are probably not up to date and it used to tell me to update them because of incompatibility problems (but I'm too lazy).

  6. #6
    Network Hub Hunchback's Avatar
    Join Date
    Jun 2012
    Location
    Europe
    Posts
    238
    Could be related to more than just the GPU really. Can't tell, i am not an expert, but from what i've gathered from the net and the official tech-support, it's a very weird bug that's hard to reproduce and track, ie the game doesn't actually "crash" it just freezes, so there's no crash dump generated by the game...

    As for drivers versions - during the time i've been having trouble with this i've changed multiple driver versions, didn't change anything. My assumption is that it's not because of/corrected by drivers.


    *shrug*
    --
    -- V. Don Quixote. Tyler Durden. Donnie Darko. Martin Sillenas. Maynard. Rorschach. You. Me.

  7. #7
    Network Hub Hunchback's Avatar
    Join Date
    Jun 2012
    Location
    Europe
    Posts
    238
    Ok guys, scratch that - the fix i posted does remove 100% the bug while exploring, doing quests even events and stuff. However once you get into something more intense (i suppose) like PvP or a dungeon, the crashing starts, thus rendering the game unplayable for me. I am really upset with this, exploring and quests are all great, but pvp and dungeons are as much a part of the game as anything else. Dunno what to do :S
    --
    -- V. Don Quixote. Tyler Durden. Donnie Darko. Martin Sillenas. Maynard. Rorschach. You. Me.

  8. #8
    Secondary Hivemind Nexus ColOfNature's Avatar
    Join Date
    Jun 2011
    Location
    μ
    Posts
    1,118
    I had a similar problem with my GTS450 playing, amongst other things, Dawn of War 2 Retribution and Just Cause 2. The video would cut out but the sound would continue. Occasionally I'd get dumped to desktop and get the message that the drivers had crashed and recovered. I finally discovered that underclocking the card by a few percent fixed it. My card was factory overclocked anyway so maybe wasn't terribly stable to begin with, but you might have some luck doing the same.
    ...common and uninteresting.
    | Steam | Desura | Twitter |

  9. #9
    Network Hub Hunchback's Avatar
    Join Date
    Jun 2012
    Location
    Europe
    Posts
    238
    What did you use to underclock it?
    --
    -- V. Don Quixote. Tyler Durden. Donnie Darko. Martin Sillenas. Maynard. Rorschach. You. Me.

  10. #10
    Secondary Hivemind Nexus ColOfNature's Avatar
    Join Date
    Jun 2011
    Location
    μ
    Posts
    1,118
    I used the app on the disc that came with the card, a thing called VTune. Your card's manufacturer will probably have something similar.
    ...common and uninteresting.
    | Steam | Desura | Twitter |

  11. #11
    Network Hub Hunchback's Avatar
    Join Date
    Jun 2012
    Location
    Europe
    Posts
    238
    I just got MSI Afterburner, but i am not sure how much i should downclock it. It was set to 715 core clock by default, 1800 on the memory. What settings did you use for stable usage?
    --
    -- V. Don Quixote. Tyler Durden. Donnie Darko. Martin Sillenas. Maynard. Rorschach. You. Me.

  12. #12
    Secondary Hivemind Nexus ColOfNature's Avatar
    Join Date
    Jun 2011
    Location
    μ
    Posts
    1,118
    I think I left the memory clock alone, and reduced the core and shader clocks from 930 and 1860 to 900 and 1800, respectively - just enough to make the card that little bit more stable without noticeably hampering its performance.
    ...common and uninteresting.
    | Steam | Desura | Twitter |

  13. #13
    Network Hub Hunchback's Avatar
    Join Date
    Jun 2012
    Location
    Europe
    Posts
    238
    I downclocked it just a tiny bit, ran a full AC story mode and didn't crash... Perhaps i am finally saved! Will report back in a while
    --
    -- V. Don Quixote. Tyler Durden. Donnie Darko. Martin Sillenas. Maynard. Rorschach. You. Me.

  14. #14
    Secondary Hivemind Nexus ColOfNature's Avatar
    Join Date
    Jun 2011
    Location
    μ
    Posts
    1,118
    Fingers crossed :-)

    I just noticed that Screwie suggested the same action some time ago. Seems to be a common problem with nvidia cards.
    ...common and uninteresting.
    | Steam | Desura | Twitter |

  15. #15
    Network Hub Hunchback's Avatar
    Join Date
    Jun 2012
    Location
    Europe
    Posts
    238
    To be honest, i was just trying to avoid that "solution"... I find it lame to downclock my stuff just because some software acts up on it. *sigh*
    --
    -- V. Don Quixote. Tyler Durden. Donnie Darko. Martin Sillenas. Maynard. Rorschach. You. Me.

  16. #16
    Network Hub Hunchback's Avatar
    Join Date
    Jun 2012
    Location
    Europe
    Posts
    238
    Ok, i tried PvP again today, since that's the fastest way to get the game to crash for me - it crashed 100% of the attempts, after a random amount of time. I tried lowering the clocks even lower, including the memory one... same result.

    Smells like GPU change time. If i had the cash :/
    --
    -- V. Don Quixote. Tyler Durden. Donnie Darko. Martin Sillenas. Maynard. Rorschach. You. Me.

  17. #17
    Obscure Node
    Join Date
    Jan 2013
    Posts
    8
    If the game keeps crashing,exiting, BOSD'ing and you're on the 310.70 from nVidia: Roll back to say 306.79 and all should be good. There were long-hauling posts around the world web about the horrors of 310.70 drivers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •