Page 1 of 4 123 ... LastLast
Results 1 to 20 of 64
  1. #1
    Obscure Node
    Join Date
    Jul 2011
    Posts
    14

    Front page load time

    The front page is, for some reason, very laggy. Perhaps scripts you are running, perhaps the multitude of sites that are being linked in.

    Trying to load or refresh the main page, takes me 5 seconds, then another 3 or 4 seconds of the screen being frozen as twitter, reddit, and so forth wait to load. Perhaps put those things below the fold instead of on the front page? or perhaps put them serverside with a redirect to the actual links?

    10 seconds may not seem like alot to wait for a page to load, but that is enough to make some one frustrated to browse a page and go elsewhere.

  2. #2
    Secondary Hivemind Nexus Rii's Avatar
    Join Date
    Jun 2011
    Location
    Aussieland
    Posts
    1,656
    Yeah, I really don't mind the ads (the occasional auto-playing ad with sound aside, those can DIAF) but the Twitter/Reddit/Facebook/etc. thing has me using AdBlock just to make the site more responsive. =/

  3. #3
    Obscure Node
    Join Date
    Jun 2011
    Posts
    11
    I second this, it's a PITA on my netbook and even mediocre notebook.

  4. #4
    Activated Node JiminyJickers's Avatar
    Join Date
    Jun 2011
    Location
    New Zealand
    Posts
    57
    Yeah plays up for me too. But mine takes minutes and does'nt load up most of the pictures.

    The comments also goes funny where I leave a comment and cannot see if afterwards. It shows in the little box to the side that shows latest comments but doesn't show up in the comments thread at all.

    Pretty strange.

  5. #5
    Obscure Node
    Join Date
    Jul 2011
    Posts
    14
    its getting worse for me :\ seriously RPS guys, fix your page.. get rid of the damn twitter and what not displays X.x

  6. #6
    Network Hub rsherhod's Avatar
    Join Date
    Jun 2011
    Posts
    305
    A thousand times yes! It's got progressively worse as more of those social network buttons have been added.

  7. #7
    Obscure Node Insolentius's Avatar
    Join Date
    Aug 2011
    Location
    Tuzla, Bosnia & Herzegovina
    Posts
    4
    I've registered solely to air my frustrations over this as well. It's making me look for news-worthy tidbits elsewhere.

  8. #8
    Obscure Node
    Join Date
    Aug 2011
    Posts
    1
    Just added these rules to adblock+ and fixed my frontpage laggy issues:

    Code:
    twitter.com$domain=www.rockpapershotgun.com
    plattform.twitter.com$domain=www.rockpapershotgun.com
    www.facebook.com$domain=www.rockpapershotgun.com
    urls.api.twitter.com$domain=www.rockpapershotgun.com
    www.reddit.com$domain=www.rockpapershotgun.com

    Hope these helps.

  9. #9
    Obscure Node
    Join Date
    Jul 2011
    Posts
    14
    oh god, amazing AKIRA_ thank you so much.
    I just sat through the page actually CRASHING while waiting for reddit to download.. :| i dont have this problem on other sites that have reddit and twitter links, but usually they have just one, not a dozen of each.. so i dunno.

  10. #10
    Network Hub ran93r's Avatar
    Join Date
    Jun 2011
    Location
    Warwick, UK.
    Posts
    111
    I feel dirty doing it but thanks Akira, just what I needed. Came here to rage as performance has been hell for the last couple of days with both Twitter and Reddit causing the whole thing to hang.

  11. #11
    Obscure Node Insolentius's Avatar
    Join Date
    Aug 2011
    Location
    Tuzla, Bosnia & Herzegovina
    Posts
    4
    Just wanted to say thanks, Akira. :)

  12. #12
    Network Hub DarkNoghri's Avatar
    Join Date
    Jun 2011
    Location
    Southeastern USA
    Posts
    131
    Is there a way to whitelist RPS, but still block those? I feel like there has to be a way, but I'm not wanting to search right now.

  13. #13
    Network Hub rsherhod's Avatar
    Join Date
    Jun 2011
    Posts
    305
    Wow, what a difference!

  14. #14
    Secondary Hivemind Nexus
    Join Date
    Jun 2011
    Posts
    1,622
    It's funny, I don't notice the social media stuff making any difference. Even when it is being slow, the rest of the page still loads fine, and its not like I notice the buttons popping in, or care.

  15. #15
    Obscure Node Insolentius's Avatar
    Join Date
    Aug 2011
    Location
    Tuzla, Bosnia & Herzegovina
    Posts
    4
    Quote Originally Posted by CMaster View Post
    It's funny, I don't notice the social media stuff making any difference. Even when it is being slow, the rest of the page still loads fine, and its not like I notice the buttons popping in, or care.
    Unlike people who have experienced no trouble whatsoever, some of us were/are unable to navigate the site before all of the facebook/twitter/reddit junk was/is loaded (it usually takes between 5-10 secs)... which was/is annoying.
    Last edited by Insolentius; 17-08-2011 at 04:41 PM.

  16. #16
    Secondary Hivemind Nexus
    Join Date
    Jun 2011
    Posts
    1,622
    Quote Originally Posted by Insolentius View Post
    Unlike people who have experienced no trouble whatsoever, some of us were/are unable to navigate the site before all of the facebook/twitter/reddit junk was/is loaded (it usually takes between 5-10 secs)... which was/is annoying.
    Oh, not doubting it was a real problem or that it should be solved. Just confused as to why it's a problem for some and not others. Down to browser? (Firefox 5 here)

  17. #17
    Obscure Node
    Join Date
    Jun 2011
    Posts
    11
    Quote Originally Posted by CMaster View Post
    Oh, not doubting it was a real problem or that it should be solved. Just confused as to why it's a problem for some and not others. Down to browser? (Firefox 5 here)
    I think it has to do with those external respond times. It still needs to disappear.

  18. #18
    Network Hub
    Join Date
    Jun 2011
    Location
    I see you
    Posts
    178
    Said this ages ago and basically got told that my internet is crap and I should sort it out lol. ever since the redesign it has gone to crap and is getting worse.

    To add to Akira_'s great listEDIT - Is the site the avatars are getting pulled from so block that and you can't see avatars.

  19. #19
    Obscure Node TaBuNiW's Avatar
    Join Date
    Aug 2011
    Posts
    5
    At the time of this post the frontpage has 42 scripts running. Eleven scripts each from twitter, reddit and facebook. I have no clue what all this scripts are for, but without them loading time is down to 1-2 seconds for me.
    Like I said, I have no clue what they are for, but are 33 scripts really needed?

  20. #20
    Have you guys heard of No Script? It's a firefox add-on. It is not as morally definite as adblock, so I shouldn't feel too bad recommending it here. Plus if you have a job you can definitely afford to subscribe and feel no moral qualms at all.

    If you don't have a job then quit eating bagels and get one. Then eat bagels.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •