Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 64
  1. #21
    Lesser Hivemind Node
    Join Date
    Jul 2011
    Posts
    800
    It's working OK again today. RPS was crashing my work browser again yesterday. :-(

  2. #22
    Network Hub
    Join Date
    Jun 2011
    Posts
    152
    Checking my network graph, the worst offender /by far/ was like.php calls for facebook. However, the sheer volume of requests to Reddit, whilst individually much quicker, also took a similar amount of time (these two alone probably were responsible for 3-4 of the six seconds load time for the front page).

    I'm not sure how good WP's caching/delivery is, but the load times on the main article images is also exceptionally slow considering their relatively-ok size. They certainly load much more slowly than the theme's background does.

  3. #23
    Obscure Node kirrus's Avatar
    Join Date
    Jun 2011
    Location
    Planet Earth.
    Posts
    71
    Estel, the main article images are actually coming straight from cache, they're not even being served by the webserver! The calls on the front page are known, trying to get them to use asynchronous loading, whenever the plugin developer pops his head back up.

    If your images are loading slowly, I'd guess that the slowness you're seeing with them isn't our end, it might be your browser taking it's time to render them, or the network connection between the RPS servers and your computer being a bit sluggish.

  4. #24
    Network Hub
    Join Date
    Jun 2011
    Posts
    152
    Hrm, interesting, thanks. Either way, it's not something that I can replicate here at the moment: I suppose it was my work connection that was at fault - I really do loathe Demon.

  5. #25
    Lesser Hivemind Node
    Join Date
    Jul 2011
    Posts
    800
    Still killing my browser today... though i have a combination of an old version of Firefox and an old unreliable PC.

  6. #26
    Obscure Node
    Join Date
    Jul 2011
    Posts
    14
    ok strangely enough the adblock stopped working today. No idea why... methods are identical, just decided to allow reddit and facebook through again :|

    edit: I got rid of facebook again, but reddit is a different story. Nothing I do gets rid of it, can hide its div, but it still freezes for about 7 seconds while trying to load it.

    edit2: ok got rid of reddit... was in an iframe now I used this:
    Code:
    *.rockpapershotgun.com*$subdocument
    Last edited by Nesetalis; 05-10-2011 at 01:50 AM.

  7. #27
    Activated Node oceanclub's Avatar
    Join Date
    Jun 2011
    Location
    Dublin, Ireland
    Posts
    81
    I can't access the front page at all today (using IE9); a script is running which freezes it, but attempting to stop the script doesn't work.

  8. #28
    Obscure Node kirrus's Avatar
    Join Date
    Jun 2011
    Location
    Planet Earth.
    Posts
    71
    A new version of the site was deployed, which may have broken your reddit blocks. The socal stuff is now loaded last, so you shouldn't find that it blocks the site loading as badly.

    Oceanclub, can you try clearing your browser cache? Also, using an alternate browser like firefox, are you able to get in?

  9. #29
    Lesser Hivemind Node Harlander's Avatar
    Join Date
    Jun 2011
    Location
    Weymouth, UK
    Posts
    763
    I have the same problem in IE8 (which circumstances force me to use here.) - multiple "this script is responding slowly" errors and a general loss of browser responsiveness. Clearing the cache seemed to have no effect.

    I had no trouble in Firefox the last time I tried (last evening I believe.)

  10. #30
    Vector Jams O'Donnell's Avatar
    Join Date
    May 2011
    Location
    Burgh of Mussels
    Posts
    830
    Okay -- I tweaked things a little bit. Is it improved at all for you guys?

  11. #31
    Lesser Hivemind Node Harlander's Avatar
    Join Date
    Jun 2011
    Location
    Weymouth, UK
    Posts
    763
    That does seem improved, yes.

  12. #32
    Activated Node TimA's Avatar
    Join Date
    Jun 2011
    Location
    Manchester, UK
    Posts
    52
    It's slightly better, but it still hangs for a bit "waiting for buttons.reddit.com" or something... I don't understand why my filters don't work any more.

  13. #33
    Obscure Node
    Join Date
    Oct 2011
    Posts
    15
    I registered just so I could give my input on this. The tweak does not fix the underlying issue with the slow page loads; the site itself loads very quickly, but then it freezes (and can not be interacted with) while waiting for the social buttons to load. It even seems to freeze the rest of the tabs in my browser (Chrome on Win 7 64 bit, if that is helpful information).

    For me, at least, they make the site completely unusable until I find new filter rules to block them. I do not know how much benefit you get from them, but for me, as a visitor to the site, they are purely detrimental.

  14. #34
    Network Hub imirk's Avatar
    Join Date
    Jun 2011
    Location
    California, USA
    Posts
    374
    Reddit and Facebook buttons, the DRM of websites!!
    Why are you wearing that stupid human suit?

  15. #35
    Obscure Node kirrus's Avatar
    Join Date
    Jun 2011
    Location
    Planet Earth.
    Posts
    71
    Quote Originally Posted by Ghostbear View Post
    [snip]For me, at least, they make the site completely unusable until I find new filter rules to block them. I do not know how much benefit you get from them, but for me, as a visitor to the site, they are purely detrimental.
    The problem is, quite a lot of people only use them to add the posts to social networks, which drives a lot of traffic to the site, which makes the advertisers happy, which pays the salaries of the writers (and pays the hosting bill). Catch 22! If someone can suggest a way to speed them up, please feel free! ;)

  16. #36
    Secondary Hivemind Nexus Rii's Avatar
    Join Date
    Jun 2011
    Location
    Aussieland
    Posts
    1,656
    Apparently putting the buttons in the articles themselves isn't an option as nobody clicks on them there. Which to my mind raises questions about the ethics of the whole enterprise.

  17. #37
    Obscure Node
    Join Date
    Oct 2011
    Posts
    15
    Quote Originally Posted by kirrus View Post
    The problem is, quite a lot of people only use them to add the posts to social networks, which drives a lot of traffic to the site, which makes the advertisers happy, which pays the salaries of the writers (and pays the hosting bill). Catch 22! If someone can suggest a way to speed them up, please feel free! ;)
    Ah, not surprised that it's fairly beneficial on your end.

    I'm not an expert on website implementations, so this might be crazy-not-actually-feasible, but could there be an intermediate page of some sort? Such that the reddit button doesn't actually go straight to the referral link, but instead goes to somewhere, that then loads the reddit data, then goes to the referral link. Or some other way to delay the loading of the reddit (/facebook / twitter / whatever else) data until someone actually clicks the button. I assume it's not feasible, otherwise it would have been done already, but that's the best idea I got.

    It's weird actually, I've never seen other sites with similar buttons having similar trouble. The big culprit seems to be the reddit button, but other places don't have an issue with them either. Perhaps it's the sheer volume of simultaneous buttons?

  18. #38
    Vector Jams O'Donnell's Avatar
    Join Date
    May 2011
    Location
    Burgh of Mussels
    Posts
    830
    Quote Originally Posted by Ghostbear View Post
    Or some other way to delay the loading of the reddit (/facebook / twitter / whatever else) data until someone actually clicks the button. I assume it's not feasible, otherwise it would have been done already, but that's the best idea I got.
    That's the solution I'm currently pondering, though I'm sure there is some value in showing how many people already like an article.

  19. #39
    Secondary Hivemind Nexus
    Join Date
    Jun 2011
    Posts
    1,780
    Is interesting to see how much files compose a page.

    The frontpage weights 2,1 MB and use 122 files. Twitter is stupid, it need lots of connections (small, about 2k)... It make sense that generate problems for some people.

    This image is big, 210 KB.
    http://www.rockpapershotgun.com/imag...8a-600x281.png
    Is big for not good reason. But I could see why the journalist would not want much image conversions, some automatic conversion. Banwitdh is cheap... troubles expensive.

    That banner for nuclear damn weights 768 KB. But banners are good friends because help pay the bills.

    I could see how RPS is a special case, because the journalist use videos from weird servers, and need all the weird setups and configs and jqueri-things of the word, is not a normal page that can be streamlined to a few files. This thing ask for "cleanup" organizing CSS and JS files, embeded CSS codes, embeded JS codes, maybe break a few bones to force everything to delay load as much as possible. But with the needs of the page its hard.

  20. #40
    Administrator Rossignol's Avatar
    Join Date
    May 2011
    Posts
    232
    Odd. The load thing has removed any freeze on the social buttons for me.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •