
<!DOCTYPE html>
<html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml">
<head profile="http://gmpg.org/xfn/11">
	
	<title>No Man&#8217;s Sky season of content &#038; events to follow multiplayer | Rock, Paper, Shotgun</title>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0" />
	<meta property="fb:pages" content="176784995741043" />
	<meta name="readability-verification" content="EDFS6HqfEsVJByL2MzxYRrype6cdTyPbjFaJAWj5"/>

			<style type="text/css" media="screen">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</style>
	
	<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Rubik:400,400i,500,700" type="text/css" media="screen" />
	<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" media="screen" />

	<link rel="pingback" href="https://www.rockpapershotgun.com/xmlrpc.php" />

	<link rel="shortcut icon" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/favicon.ico" />
	
	<link rel="icon" type="image/png" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/favicon-16x16.png" sizes="16x16" />
	<link rel="icon" type="image/png" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/favicon-32x32.png" sizes="32x32" />
	<link rel="icon" type="image/png" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/favicon-96x96.png" sizes="96x96" />
	<link rel="icon" type="image/png" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/favicon-128.png" sizes="128x128" />
	<link rel="icon" type="image/png" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/favicon-196x196.png" sizes="196x196" />

	<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/apple-touch-icon-57x57.png" />
	<link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/apple-touch-icon-60x60.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/apple-touch-icon-72x72.png" />
	<link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/apple-touch-icon-76x76.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/apple-touch-icon-114x114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/apple-touch-icon-120x120.png" />
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/apple-touch-icon-144x144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/favicons/apple-touch-icon-152x152.png" />
	
	<!-- Google Analytics RPS -->
<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-2667859-1', 'auto');

    ga('require', 'displayfeatures');
    ga('require', 'linkid', 'linkid.js');

            ga('set', 'dimension4', '0');
    
            ga('set', 'dimension1', "news,pc-game-news");
        ga('set', 'dimension2', "hello-games");
        ga('set', 'dimension3', "Alice O'Connor");
    
    ga('send', 'pageview');

</script>
<!-- End Google Analytics RPS -->
	
	
	<meta name="twitter:card" value="summary" />
	<meta name="twitter:url" value="https://www.rockpapershotgun.com/2018/07/23/no-mans-sky-first-season-of-content-and-events/" />
	<meta name="twitter:title" value="No Man&#8217;s Sky season of content &#038; events to follow multiplayer" />
	<meta name="twitter:description" value="Proper fancy &#8216;pootle around space with your spacepals&#8216; online multiplayer will arrive in No Man&#8217;s Sky with the &#8216;Next&#8217; update on Tuesday, we&#8217;ve known for a while, and I&#8217;m surprised to hear developers Hello Games already talking about what&#8217;s next after Next. They have planned a season of &#8220;weekly content and community events&#8221; to start [&hellip;]" />
	<meta name="twitter:image" value="https://assets.rockpapershotgun.com/images/2018/07/no-mans-sky-next-trailer-cap.jpg" />
	<meta name="twitter:site" value="@rockpapershot" />
	<meta name="twitter:creator" value="@rockpapershot" />

	
<!-- All in One SEO Pack 2.3.13.2 by Michael Torbert of Semper Fi Web Design[173,322] -->
<meta name="description"  content="Proper fancy ‘pootle around space with your spacepals‘ online multiplayer will arrive in No Man’s Sky with the ‘Next’ update on" />

<meta name="keywords"  content="hello games" />

<link rel="canonical" href="https://www.rockpapershotgun.com/2018/07/23/no-mans-sky-first-season-of-content-and-events/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//www.rockpapershotgun.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Rock Paper Shotgun - PC Game Reviews, Previews, Subjectivity &raquo; Feed" href="https://www.rockpapershotgun.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rock Paper Shotgun - PC Game Reviews, Previews, Subjectivity &raquo; Comments Feed" href="https://www.rockpapershotgun.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rock Paper Shotgun - PC Game Reviews, Previews, Subjectivity &raquo; No Man&#8217;s Sky season of content &#038; events to follow multiplayer Comments Feed" href="https://www.rockpapershotgun.com/2018/07/23/no-mans-sky-first-season-of-content-and-events/feed/" />
    <meta property="og:title" content="No Man&#8217;s Sky season of content &#038; events to follow multiplayer"/>
    <meta property="og:type" content="article"/>
    <meta property="og:url" content="https://www.rockpapershotgun.com/2018/07/23/no-mans-sky-first-season-of-content-and-events/"/>
    <meta property="og:site_name" content="Rock Paper Shotgun"/>
    <meta property="og:image" content="https://assets.rockpapershotgun.com/images/2018/07/no-mans-sky-next-trailer-cap.jpg"/>
    		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rockpapershotgun.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bbspoiler-css'  href='https://www.rockpapershotgun.com/wp-content/plugins/bbspoiler/inc/bbspoiler.css?ver=4.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.rockpapershotgun.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.rockpapershotgun.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.rockpapershotgun.com/wp-content/plugins/wp-gfycat/js/gfycat_test_.js?ver=4.9.2'></script>
<script type='text/javascript' src='https://code.jquery.com/jquery-3.3.1.min.js?ver=4.9.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var title = {"unfolded":"Expand","folded":"Collapse"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rockpapershotgun.com/wp-content/plugins/bbspoiler/inc/bbspoiler.js?ver=4.9.2'></script>
<link rel='https://api.w.org/' href='https://www.rockpapershotgun.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rockpapershotgun.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rockpapershotgun.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='BenQ GW2480 review: A cheap, no-frills monitor' href='https://www.rockpapershotgun.com/2018/07/23/benq-gw2480-review/' />
<link rel='next' title='Teaching proper fighting etiquette in Absolver' href='https://www.rockpapershotgun.com/2018/07/23/teaching-proper-fighting-etiquette-in-absolver/' />
<meta name="generator" content="WordPress 4.9.2" />
<link rel='shortlink' href='https://wp.me/pkbbD-2oub' />
<link rel="alternate" type="application/json+oembed" href="https://www.rockpapershotgun.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rockpapershotgun.com%2F2018%2F07%2F23%2Fno-mans-sky-first-season-of-content-and-events%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rockpapershotgun.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rockpapershotgun.com%2F2018%2F07%2F23%2Fno-mans-sky-first-season-of-content-and-events%2F&#038;format=xml" />
			<meta property="fb:pages" content="176784995741043" />
			
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel="amphtml" href="https://www.rockpapershotgun.com/2018/07/23/no-mans-sky-first-season-of-content-and-events/amp/" /></head>
<body class="ads-enabled">


<div class="breaking">
	<p>
					<a href="/2017/11/24/best-pc-games">The best PC games ever</a>
					<a href="https://www.rockpapershotgun.com/2018/07/18/the-bestest-and-most-top-pc-games-of-2018-so-far/">The best PC games of 2018 so far</a>
					<a href="https://www.rockpapershotgun.com/2018/05/21/best-graphics-card-2018/">Best graphics cards 2018</a>
					<a href="https://www.rockpapershotgun.com/2016/10/31/the-50-best-free-games-on-pc/">Best free games</a>
					<a href="https://www.rockpapershotgun.com/2018/07/18/rainbow-six-siege-operators-who-to-pick-and-how-to-use-them/">Rainbow Six Siege operators guide</a>
			</p>
</div>
<header class="header-desktop">
	<div class="container">
		<a href="https://www.rockpapershotgun.com" class="logo"><img src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/logo.svg" alt="Rock Paper Shotgun"/></a>

		
<nav class="primary">
			<a href="/category/featured-articles">Features</a>
			<a href="/pc-game-reviews">Reviews</a>
			<a href="/category/pc-game-news">News</a>
			<a href="/category/hardware">Hardware</a>
			<a href="/videos">Videos</a>
			<a href="/guides">Guides</a>
			<a href="/supporters-only">Supporters Only</a>
	</nav>

<nav class="secondary">
			<a href="/tag/premature-evaluation">Premature Evaluation</a>
			<a href="/tag/update-night">Update Night</a>
			<a href="/tag/the-mechanic/">The Mechanic</a>
			<a href="/tag/the-flare-path/">The Flare Path</a>
			<a href="/category/free-pc-games">Free PC games</a>
			<a href="/tag/podcast/">Podcast</a>
			<a href="https://forum.rockpapershotgun.com/">Forum</a>
	</nav>		
		
<div class="account signed-out">
			<p class="status">Not signed in.</p>
		<div class="actions">
			<a href="https://www.rockpapershotgun.com/wp-login.php?redirect_to=2018%2F07%2F23%2Fno-mans-sky-first-season-of-content-and-events" class="button tight">Sign in</a>
			<a href="https://www.rockpapershotgun.com/wp-login.php?action=register" class="button tight">Create an account</a>
		</div>

	</div>
		<div class="support-us">
				<a href="/support-us" class="button wide">Support us</a>
	</div>		<div class="search">
	<form method="get" action="/search">
		<input type="text" name="q" placeholder="Search the site"/>
		<button class="button">Go</button>
	</form>
</div>
	</div>
</header>
<div class="stream-widget">
	<div class="stream-bar">
		<div class="stream-bar-toggle"></div>
		<div class="container-1260">
			<a href class="stream-link">
				<span class="stream-live">Now streaming live:</span>
				<span class="stream-title"></span>
			</a>
			<span class="stream-toggle button"></span>
		</div>
	</div>
	<div class="container-1260">
		<div class="stream-player-wrapper">
			<div id="stream-player"></div>
		</div>
	</div>
</div>


<div id="page-wrapper">

			<div class="leaderboards">
					<div
			class="ad-desktop ad-hd ad-leaderboard-top-desktop"
			data-dfp-id="RPS_LB_1"
			data-dfp-sizes="728x90,970x250,1260x110,1260x250"
			data-dfp-targeting="site=rockpapershotgun.com"
			id="div-ga-RPS_LB_1"
			data-ghost-zone="25"		></div>
						<div
			class="ad-tablet ad-leaderboard-top-tablet"
			data-dfp-id="RPS_LB_1"
			data-dfp-sizes="728x90"
			data-dfp-targeting="site=rockpapershotgun.com"
			id="div-ga-RPS_LB_1_TABLET"
			data-ghost-zone="25"		></div>
			</div>
	
	<div id="page" class="page">
		<main>


	<div class="above">
		
			<article class="
				article
															">				
				
<header>
	<nav class="breadcrumb">
		<ul>
							<li>
					<a href="https://www.rockpapershotgun.com" rel="v:url" property="v:title">Home</a>
					<span>&bull;</span>
				</li>
							<li>
					<a href="/category/pc-game-news" rel="v:url" property="v:title">News</a>
					<span>&bull;</span>
				</li>
							<li>
					<a href="https://www.rockpapershotgun.com/game/no-mans-sky" rel="v:url" property="v:title">No Man's Sky</a>
					<span>&bull;</span>
				</li>
					</ul>
	</nav>

	<div class="details">

				
			<a href="#comments" class="comment-count ">
			<i class="fa fa-comment-o"></i>
			4		</a>
	
		<h1 class="title">No Man's Sky season of content & events to follow&nbsp;multiplayer</h1>

		
		<div class="metadata">
			<a href="https://www.rockpapershotgun.com/author/aliceoconnor/" class="avatar" style="background-image:url(https://secure.gravatar.com/avatar/9a89fae42799926a0d09a21b15253ab5?s=56&d=monsterid&r=pg)" class="avatar"></a>
			<p class="author-name">
				<a href="https://www.rockpapershotgun.com/author/aliceoconnor/">Alice O'Connor</a>
			</p>
			<p class="author-job-title">News Editor</p>
			<p class="publication-date">23rd July 2018 / 06:23PM</p>
		</div>
	</div>

			
	<div class="image-grid count-1">
						
						
			<div class="image">
																	
				
											<img src="https://assets.rockpapershotgun.com/images/2018/07/no-mans-sky-next-trailer-cap.jpg/RPSS/resize/760x-1/format/jpg/quality/70" title="I always wanted you to into space, man." width="1920" height="1080" class="alignnone size-full wp-image-570809" />					
							</div>
			</div>
	
</header>
				<main>
					<p>Proper fancy &#8216;<a href="https://www.rockpapershotgun.com/2018/07/17/no-mans-sky-goes-full-multiplayer-next-week/">pootle around space with your spacepals</a>&#8216; online multiplayer will arrive in <a href="https://www.rockpapershotgun.com/game/no-mans-sky/">No Man&#8217;s Sky</a> with the &#8216;Next&#8217; update on Tuesday, we&#8217;ve known for a while, and I&#8217;m surprised to hear developers Hello Games already talking about what&#8217;s next after Next. They have planned a season of &#8220;weekly content and community events&#8221; to start &#8220;a little while after&#8221; Next&#8217;s launch, they say. They don&#8217;t say more about what those plans are but coo, go on, more spacestuff, I&#8217;ll take that.</p>
<p>&#8220;A little while after the release of No Man&#8217;s Sky Next, Hello Games has planned its first season of weekly content and community events,&#8221; is exactly what boss man Sean Murray said in <a href="https://www.nomanssky.com/2018/07/a-message-to-the-community/">today&#8217;s post</a>. &#8220;This will be free for all players, with no microtransactions.&#8221;</p>
<p>I don&#8217;t know if I&#8217;d read that to mean weekly content updates as much as weekly <em>somethings</em>, but I don&#8217;t doubt Hello Games are certain they can deliver on whatever their plan is. They are cautious with declarations about the future now, given the bileful overreactions to anything involving No Man&#8217;s Sky &#8216;promises&#8217;.</p>
<p>Hello Games are also launching <a href="https://galacticatlas.nomanssky.com/">the Galactic Atlas</a>, a website which will feature nice and interesting places submitted by No Man&#8217;s Sky players. Could have called it Warp Advisor.</p>
<p>&#8220;Following Foundation, Pathfinder and Atlas Rises, we really want to include you, the community, more,&#8221; Murray said. &#8220;We know that a million gamers played on the day we launched Atlas Rises. That everyone who bought Atlas Rises played for 45 hours on average and 90% rated it positively. We know that 20% of players hit over 100 hours, and 5% hit over 1000. We know that over 200 million hours of No Man&#8217;s Sky have been played to date. It makes us happy, but desperate to communicate better.&#8221;</p>
<p>Communication is a two-way street, mind. Murray has been chatting with that there games media recently, and I liked this <a href="https://waypoint.vice.com/en_us/article/zmk4w8/we-spent-an-hour-talking-to-hello-games-about-everything-no-mans-sky">with Waypoint</a> about reactions to the initial launch:</p>
<blockquote>
<p>&#8220;The reality is&#8230; a perspective that I&#8217;ve gained, I think, and gained in this first few months is [pause] the Internet is often really, really good at figuring out when someone&#8217;s made a mistake, right? Or messed up in some way, done something that they would regret. [But] I don&#8217;t necessarily think they&#8217;re the best at deciding what appropriate action is or exact proportional reaction to take.&#8221;</p>
</blockquote>
<p>No kidding, huh?</p>
<p>The No Man&#8217;s Sky Next update is due to launch tomorrow, Tuesday the 24th. I imagine some of our space cadets will blast off and find ways to die foolishly together. Along with multiplayer, the update will bring a polishing of planet generation and other prettybits, as well as features deeper in the guts such as commanding fleets of frigates.</p>
<p><div class="embed-wrapper"><iframe width="690" height="389" src="https://www.youtube.com/embed/h3HphgSn0o4?rel=0&amp;showinfo=0" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></div></p>
<p><em>Disclosure: our own Alec Meer wrote some words for No Man&#8217;s Sky back in the day. Still not sure exactly what. Words? For a story thing. Y&#8217;know, words, the squiggly lines that would look like alien glyphs if we didn&#8217;t know them.</em></p>

									</main>

			</article>
			
			
	<script type="application/ld+json">
		{
			"@context": "http://schema.org",
			"@type": "NewsArticle",
			"mainEntityOfPage": "https://www.rockpapershotgun.com/2018/07/23/no-mans-sky-first-season-of-content-and-events/",
			"headline": "No Man's Sky season of content &amp; events to follow multiplayer",
			"datePublished": "4 hours ago",
			"image": {
				"@type": "ImageObject",
				"url": "https://assets.rockpapershotgun.com/images/2018/07/no-mans-sky-next-trailer-cap.jpg"
			},
			"author": {
				"@type": "Person",
				"name": "Alice O'Connor"
			},
			"publisher": {
				"@type": "Organization",
				"logo": {
					"@type": "ImageObject",
					"url": "https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/logo-amp.png",
					"width": 861,
					"height": 66				},
				"name": "Rock Paper Shotgun"
			}
		},
		{
			"@context": "http://schema.org",
			"@type": "BreadcrumbList",
			"itemListElement": [
							,				{
					"@type": "ListItem",
					"position": 0,
					"item": {
						"@id": "https://www.rockpapershotgun.com",
						"name": "Home"
					}
				}
											{
					"@type": "ListItem",
					"position": 1,
					"item": {
						"@id": "/category/pc-game-news",
						"name": "News"
					}
				}
											{
					"@type": "ListItem",
					"position": 2,
					"item": {
						"@id": "https://www.rockpapershotgun.com/game/no-mans-sky",
						"name": "No Man's Sky"
					}
				}
						]
		}
			</script>
	

			<div class="container-690">

				        <p class="tags">
            Tagged with                            <a href="https://www.rockpapershotgun.com/tag/hello-games/" rel="tag">Hello Games</a>,                            <a href="https://www.rockpapershotgun.com/game/no-mans-sky/" rel="tag">No Man's Sky</a>.                    </p>
        

				<p class="disclaimer">
					If you click our links to online stores and make a purchase we may receive a few pennies. Find more information <a href="/affiliate-linking-policy/">here</a>.				</p>

									<div class="comments-jump">
						<a href="#comments" class="button">Jump to comments (4)</a>
					</div>
				
				
					
			<div class="related-games count-1" id="related-games">
			
						
			<div class="related-games-list">

									
					<div class="related-game-item">
						<div class="details">
							<p class="title">
																	<a href="/game/no-mans-sky">More about No Man's Sky</a>
															</p>
							<ul>
											
																	<li><a href="/game/no-mans-sky/?type=guides">Guides</a></li>
											
																	<li><a href="/game/no-mans-sky/?type=pc-game-news">News</a></li>
											
																	<li><a href="/game/no-mans-sky/?type=featured-articles">Features</a></li>
											
															</ul>
						</div>
					</div>
							</div>
			
					</div>

				

		
				
				<div class="about-the-author">
					<p class="section-title">Who am I?</p>
					<div class="container">
													<a href="https://www.rockpapershotgun.com/author/aliceoconnor/" class="avatar" style="background-image:url(https://secure.gravatar.com/avatar/9a89fae42799926a0d09a21b15253ab5?s=256&d=monsterid&r=pg);" title="Picture of Alice O'Connor"></a>
						
						<div class="details">
							<p class="name">Alice O'Connor</p>

															<p class="job-title">News Editor</p>
							
															<p class="description">When not writing news, Alice may be found in the sea.</p>
							
							<p>
								<a href="https://www.rockpapershotgun.com/author/aliceoconnor/" class="button">More by me</a>
							</p>
						</div>
					</div>
				</div>

				
	<a href="/support-us" class="support-us-promo">
		<span class="logo">
			<img src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/logo-inverted.svg" alt="Rock Paper Shotgun"/>
		</span>
		
		<span class="message-container">
			<span class="message">
				Support RPS and get an ad-free site, extra articles, and free stuff!			</span>
			
			<span class="button">Tell me more</span>
		</span>
		
		<span class="artwork"></span>
	</a>
			</div>

			</div>

	<div class="below">
									<div class="billboard-container collapsible">
												<div
			class=" ad-leaderboard-low"
			data-dfp-id="RPS_LB_2"
			data-dfp-sizes="728x90,970x250,1200x500"
			data-dfp-targeting="site=rockpapershotgun.com"
			id="div-ga-RPS_LB_2"
					></div>
					</div>
						
					<div id="recommendations">
			<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
			<ins
				class="adsbygoogle"
				style="display:block"
				data-ad-format="autorelaxed"
				data-matched-content-ui-type="image_stacked,image_stacked"
				data-matched-content-rows-num="5,1"
				data-matched-content-columns-num="1,5"
				data-ad-client="ca-pub-4560360103312331"
				data-ad-slot="9398367471"></ins>
		</div>

	
					
		<div id="comments">
			<div class="comments-container">
				<p class="section-title">
					<img src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/comment-icon.png" alt=""/>
					Comments				</p>
				
															<div class="alert">
							<p>Please <a href="/wp-login.php">log in</a> to reply.</p>
						</div>
									
				<div class="comments-list">
					<div class="alert">Please enable Javascript to view comments.</div>
				</div>
				
									<div id="comments-mpu-container" class="mpu-container">
								<div
			class="lazyload ad-lazyload"
			data-dfp-id="RPS_Lazy_Load_HP_MPU"
			data-dfp-sizes="300x250"
			data-dfp-targeting="site=rockpapershotgun.com,lazyload=true,sticky=false,position=rockpapershotgun.comcomments-mpu"
			id="div-ga-RPS_Lazy_Load_HP_MPUcomments-mpu"
					></div>
						</div>
							</div>
			
			<script src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/js/Comments.js?v2.0.5"></script>
			<script>
				$(document).ready( function() {
					var c = new Comments({
						aid: 570783,
						uid: 0,
						lang: {
							loading: "Loading... bleep... bloop...",
							post: "Opinion, away!",
							updating: "Updating...",
							error: "An error has occurred. We are so sorry."
						}
					});
				});
			</script>
		</div>

			
							
	
			<div class="spotlight-bar ">
			<p class="section-title">More of this sort of thing</p>
			<div class="grid">
										
					<div class="grid-3">
						<div class="spotlight-bar-item">
							<a href="https://www.rockpapershotgun.com/2017/08/24/no-mans-sky-atlas-pass/" class="cover" style="background-image:url(https://assets.rockpapershotgun.com/images//2017/08/noms3.jpg/RPSS/resize/274x-1/format/jpg/quality/70)"></a>
							
							<p class="title"><a href="https://www.rockpapershotgun.com/2017/08/24/no-mans-sky-atlas-pass/">With Atlas Rises, it's worth returning to No Man's Sky</a></p>
							<p class="byline">
								11 months ago																	<span>&bull;</span>
											
			<a href="https://www.rockpapershotgun.com/2017/08/24/no-mans-sky-atlas-pass/#comments" class="comment-count ">
			<i class="fa fa-comment-o"></i>
			53		</a>
																</p>
						</div>
					</div>
										
					<div class="grid-3">
						<div class="spotlight-bar-item">
							<a href="https://www.rockpapershotgun.com/2016/08/15/no-mans-sky-pc-review/" class="cover" style="background-image:url(https://www.rockpapershotgun.com/images/16/aug/nm/09nm.jpg/RPSS/resize/274x-1/format/jpg/quality/70)"></a>
							
							<p class="title"><a href="https://www.rockpapershotgun.com/2016/08/15/no-mans-sky-pc-review/">Wot I Think: No Man's Sky</a></p>
							<p class="byline">
								2 years ago																	<span>&bull;</span>
											
			<a href="https://www.rockpapershotgun.com/2016/08/15/no-mans-sky-pc-review/#comments" class="comment-count ">
			<i class="fa fa-comment-o"></i>
			261		</a>
																</p>
						</div>
					</div>
										
					<div class="grid-3">
						<div class="spotlight-bar-item">
							<a href="https://www.rockpapershotgun.com/2016/08/11/no-mans-sky-impressions/" class="cover" style="background-image:url(https://www.rockpapershotgun.com/images/16/aug/nmm08.jpg/RPSS/resize/274x-1/format/jpg/quality/70)"></a>
							
							<p class="title"><a href="https://www.rockpapershotgun.com/2016/08/11/no-mans-sky-impressions/">No Man's Sky Impressions</a></p>
							<p class="byline">
								2 years ago																	<span>&bull;</span>
											
			<a href="https://www.rockpapershotgun.com/2016/08/11/no-mans-sky-impressions/#comments" class="comment-count ">
			<i class="fa fa-comment-o"></i>
			163		</a>
																</p>
						</div>
					</div>
										
					<div class="grid-3">
						<div class="spotlight-bar-item">
							<a href="https://www.rockpapershotgun.com/2016/08/24/no-mans-sky-guide-top-hints-and-tips-for-survival/" class="cover" style="background-image:url(https://www.rockpapershotgun.com/images/16/aug/no-mans-sky-hub-guide-black-hole-travel.jpg/RPSS/resize/274x-1/format/jpg/quality/70)"></a>
							
							<p class="title"><a href="https://www.rockpapershotgun.com/2016/08/24/no-mans-sky-guide-top-hints-and-tips-for-survival/">No Man’s Sky Guide: Top Hints And Tips For Survival</a></p>
							<p class="byline">
								2 years ago																	<span>&bull;</span>
											
			<a href="https://www.rockpapershotgun.com/2016/08/24/no-mans-sky-guide-top-hints-and-tips-for-survival/#comments" class="comment-count ">
			<i class="fa fa-comment-o"></i>
			49		</a>
																</p>
						</div>
					</div>
							</div>

					</div>
	
			
							<div class="billboard-container collapsible">
							<div
			class=" ad-leaderboard-last"
			data-dfp-id="RPS_LEADERBOARD_LAST"
			data-dfp-sizes="728x90, 970x250"
			data-dfp-targeting="site=rockpapershotgun.com"
			id="div-ga-RPS_LEADERBOARD_LAST"
					></div>
					</div>
				
			<p class="section-title">Latest videos</p>
			<div class="video-hub in-article">
				<i class="fa fa-circle-o-notch fa-spin fa-2x fa-fw loading-spinner" aria-hidden="true"></i>

				<div class="video-player">
					<div class="player-wrapper">
						<div class="player"></div>
					</div>
					<div class="details">
						<h3 class="title"></h3>
						<p class="description"></p>
					</div>
				</div>
		
				<div class="video-archive"></div>
				
				<div class="video-actions">
					<a class="button watch-more">Watch more on YouTube</a>
					<a class="button outline subscribe">Subscribe to our channel</a>
				</div>
			</div>
	
			
	
			<div class="spotlight-bar small">
			<p class="section-title">Latest articles</p>
			<div class="article-container">
				<div class="grid">
													
						<div class="grid-3">
							<div class="spotlight-bar-item">
								<a href="https://www.rockpapershotgun.com/2018/07/23/fallout-76-beta-details-confirmed/" class="cover" style="background-image:url(https://assets.rockpapershotgun.com/images/2018/07/F76-1.jpg/RPSS/resize/274x-1/format/jpg/quality/70)"></a>
								
								<p class="title"><a href="https://www.rockpapershotgun.com/2018/07/23/fallout-76-beta-details-confirmed/">Fallout 76's beta begins October, but not everyone gets in on day 1</a></p>
										
								</div>
						</div>
													
						<div class="grid-3">
							<div class="spotlight-bar-item">
								<a href="https://www.rockpapershotgun.com/2018/07/23/the-joy-of-getting-lost-in-shape-of-the-world/" class="cover" style="background-image:url(https://assets.rockpapershotgun.com/images/2018/07/shape-of-the-world.jpg/RPSS/resize/274x-1/format/jpg/quality/70)"></a>
								
								<p class="title"><a href="https://www.rockpapershotgun.com/2018/07/23/the-joy-of-getting-lost-in-shape-of-the-world/">The Joy of getting lost in Shape of the World</a></p>
										
								</div>
						</div>
													
						<div class="grid-3">
							<div class="spotlight-bar-item">
								<a href="https://www.rockpapershotgun.com/2018/07/23/european-speedrunner-assembly-live/" class="cover" style="background-image:url(https://assets.rockpapershotgun.com/images/2018/07/Screenshot_5-1.jpg/RPSS/resize/274x-1/format/jpg/quality/70)"></a>
								
								<p class="title"><a href="https://www.rockpapershotgun.com/2018/07/23/european-speedrunner-assembly-live/">The European Speedrunner Asssembly charity marathon runs all week</a></p>
										
			<a href="https://www.rockpapershotgun.com/2018/07/23/european-speedrunner-assembly-live/#comments" class="comment-count ">
			<i class="fa fa-comment-o"></i>
			1		</a>
								</div>
						</div>
													
						<div class="grid-3">
							<div class="spotlight-bar-item">
								<a href="https://www.rockpapershotgun.com/2018/07/23/noclip-gog-documentary-video/" class="cover" style="background-image:url(https://assets.rockpapershotgun.com/images/2018/07/Screenshot_3-2.jpg/RPSS/resize/274x-1/format/jpg/quality/70)"></a>
								
								<p class="title"><a href="https://www.rockpapershotgun.com/2018/07/23/noclip-gog-documentary-video/">Noclip's latest documentary charts the rise of GOG</a></p>
										
			<a href="https://www.rockpapershotgun.com/2018/07/23/noclip-gog-documentary-video/#comments" class="comment-count ">
			<i class="fa fa-comment-o"></i>
			3		</a>
								</div>
						</div>
									</div>
				
							</div>
			
							<div class="mpu-container">
							<div
			class="lazyload ad-lazyload"
			data-dfp-id="RPS_Lazy_Load_HP_MPU"
			data-dfp-sizes="300x250"
			data-dfp-targeting="site=rockpapershotgun.com,lazyload=true,sticky=false,position=rockpapershotgun.com"
			id="div-ga-RPS_Lazy_Load_HP_MPU"
					></div>
					</div>
					</div>
	
		
	</div>


<script src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/js/VideoHub.js?v2.0.5"></script>
<script>
	$(document).ready(function() {
		new VideoHub({
			lang: {
				error: "Oh no! Something went wrong.",
			},
			limit: 6,
			canUpdateHistory: false,
			version: "desktop",
			autoplay: false
		});
	});
</script>




		</main>

					<aside>
				<div id="skyscraper">
							<div
			class="ad-hd ad-halfpage"
			data-dfp-id="RPS_HP"
			data-dfp-sizes="300x250,160x600,300x600,300x1050"
			data-dfp-targeting="site=rockpapershotgun.com"
			id="div-ga-RPS_HP"
			data-ghost-zone="26"		></div>
					</div>

				<div id="right-rail"></div>
			</aside>
			</div>
</div>


<footer class="footer">
	<div class="container-1260">
		<div class="about">
			<a href="https://www.rockpapershotgun.com" class="logo">
				<img src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/images/logo.svg" alt="Rock Paper Shotgun"/>
			</a>
			<p>&copy; 2018 Gamer Network.</p>
			<p>Today's scotch egg consumption: 3632</p>
			<p>Hivemind Throbometer reading: 0.301%</p>
		</div>

					<div class="explore">
				<p class="section-title">Explore</p>
				<ul>
											<li>
							<a href="/category/featured-articles">Features</a>
						</li>
											<li>
							<a href="/pc-game-reviews">Reviews</a>
						</li>
											<li>
							<a href="/category/pc-game-news">News</a>
						</li>
											<li>
							<a href="/category/hardware">Hardware</a>
						</li>
											<li>
							<a href="/videos">Videos</a>
						</li>
											<li>
							<a href="/guides">Guides</a>
						</li>
											<li>
							<a href="/supporters-only">Supporters Only</a>
						</li>
										<li>
						<a href="https://soundcloud.com/rockpapershotgun">Podcast</a>
					</li>
					<li>
						<a href="/authors">Author index</a>
					</li>
					<li>
						<a href="/games?letter=a">Game index</a>
					</li>
					<li>
						<a href="/tags?letter=a">Topic index</a>
					</li>
				</ul>
			</div>
			
			<div class="staff">
				<p class="section-title">Staff</p>
				<ul>
											<li>
							<a href="https://www.rockpapershotgun.com/author/gonnas/">Graham Smith</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/alicebell/">Alice Bell</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/aliceoconnor/">Alice O'Connor</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/brendan-caldwell/">Brendan Caldwell</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/katharinebyrne/">Katharine Castle</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/ento/">Alec Meer</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/botherer/">John Walker</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/coxmatt/">Matt Cox</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/daveirwin/">Dave Irwin</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/matthew-castle/">Matthew Castle</a>
						</li>
											<li>
							<a href="https://www.rockpapershotgun.com/author/noasmith/">Noa Smith</a>
						</li>
									</ul>
			</div>
			
			<div class="helpful-links">
				<p class="section-title">Helpful links</p>
				<ul>
					<li><a href="/about-pc-gaming-rps">About us</a></li>
<li><a href="mailto:contact@rockpapershotgun.com">Contact us</a></li>
<li><a href="https://forum.rockpapershotgun.com">Forum</a></li>
<li><a href="http://feeds.feedburner.com/RockPaperShotgun">RSS</a></li>
<li><a href="/privacy">Privacy policy</a></li>
<li>
	<a href="https://www.facebook.com/rockpapershot"><i class="fa fa-facebook"></i></a>
	<a href="https://twitter.com/rockpapershot"><i class="fa fa-twitter"></i></a>
	<a href="https://steamcommunity.com/groups/rps"><i class="fa fa-steam"></i></a>
</li>

				</ul>
			</div>
			
			<div class="network">
				<p class="section-title">Gamer Network</p>
				<ul>
					<li><a href="https://www.eurogamer.net" target="_blank">Eurogamer</a></li>
					<li><a href="https://www.gamesindustry.biz" target="_blank">GamesIndustry.biz</a></li>
					<li><a href="https://www.gamersedition.com" target="_blank">Gamer's Edition</a></li>
					<li><a href="https://www.jelly.deals" target="_blank">Jelly Deals</a></li>
					<li><a href="https://www.metabomb.net" target="_blank">Metabomb</a></li>
					<li><a href="http://www.nintendolife.com" target="_blank">Nintendo Life</a></li>
					<li><a href="http://www.pushsquare.com" target="_blank">Push Square</a></li>
					<li><a href="https://www.usgamer.net" target="_blank">USgamer</a></li>
					<li><a href="https://www.vg247.com" target="_blank">VG247</a></li>
				</ul>
			</div>

			<div class="events">
				<p class="section-title">Events</p>
				<ul>
					<li><a href="https://www.egx.net/egx" target="_blank">EGX</a></li>
					<li><a href="https://www.egx.net/berlin" target="_blank">EGX Berlin</a></li>
					<li><a href="https://www.egx.net/rezzed" target="_blank">EGX Rezzed</a></li>
					<li><a href="https://www.mcmcomiccon.com" target="_blank">MCM Comic-Con</a></li>
					<li><a href="http://www.paxsite.com" target="_blank">PAX</a></li>
					<li><a href="http://www.starwarscelebration.com" target="_blank">Star Wars Celebration</a></li>
				</ul>
			</div>
				
	</div>
</footer>

<script>
	$(document).ready(function() {
		$("img[alt]").each(function(i) {
			$(this).attr('title', $(this).attr('alt'));
		});
	});
</script>

<script src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/js/StreamWidget.js?v2.0.5" defer="defer"></script>
<script>
	$(document).ready(function() {
		let args = {
			lang: {
				show: "Show stream",
				hide: "Hide stream"
			},
			version: "desktop"
		};
		new StreamWidget(args);
	});
</script>


		
				
		<script>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</script>
	
    <script>

        jQuery(document).ready(function() {

            var custom_variables = {};
            custom_variables['source'] = 'article';
            custom_variables['url'] = document.location.pathname.substr(0, 40);
            custom_variables['tags'] = "simulation,news,pc-game-news,hello-games";
            
                            var dfp_npa = 'false';
            
                            var ads_space = 450;
            
            if(Cookies.getJSON('dfp-npa') && Cookies.getJSON('dfp-npa').status == 'true') {
                dfp_npa = 'true';
            } 
            if(Cookies.getJSON('dfp-npa') && Cookies.getJSON('dfp-npa').status == 'false') {
                dfp_npa = 'false';
            } 
            if(Cookies.getJSON('dfp-npa') && Cookies.getJSON('dfp-npa').chosen == 'true') {
                if(Cookies.getJSON('dfp-npa').status == 'true') {
                    custom_variables['dfp_personalisation'] = 'no';
                } else {
                    custom_variables['dfp_personalisation'] = 'yes';
                }
            } else {
                custom_variables['dfp_personalisation'] = 'none';
            }

            try {
                jQuery('.ad-tablet .ad-desktop, .ad-mobile, .ad-hd, .ad-leaderboard-low, .ad-leaderboard-last').getDFPads({
                    'custom_variables' : custom_variables,
                    'lazyload_spacer': ads_space,
                    'showNonPersonalisedAds': dfp_npa
                });
            } catch(e) {
            }

            if(dfp_npa == 'true') {
                (adsbygoogle = window.adsbygoogle || []).requestNonPersonalizedAds=1;
            } else {
                (adsbygoogle = window.adsbygoogle || []).requestNonPersonalizedAds=0;
            }
            window.adsbygoogle.push({});
        });

    </script>

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "8518622" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=8518622&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

			<script	  type = "text/javascript">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</script>
	
<script src="//s.skimresources.com/js/87431X1560958.skimlinks.js"></script>

		<script>
			function mormontLoaded () {
				mormont('set', 'section', 'article');
				mormont('set', 'language', 'en');
				mormont('set', 'platforms', ["pc"]);
				mormont('set', 'published', "2018-07-23T18:23:52+00:00");
				mormont('set', 'article_type', "news");
				mormont('set', 'author', "Alice O'Connor"); 
				mormont('set', 'tags', ['tag:hello-games','game:no-mans-sky']); 
				mormont('send', 'pageview');
									mormont('configure', 'property', 'rockpapershotgun');
					mormont('configure', 'label', "You may also like&hellip;");
					mormont('configure', 'recommendations_site', 'www.rockpapershotgun.com');
					mormont('configure', 'selector', 'article > main');
					mormont('configure', 'render_recommendations', true);
					mormont('configure', 'max_rec_links', 2);
					mormont('configure', 'max_containers', 2);
					mormont('configure', 'size_breakpoint', 0);
					mormont('fetchRecommendations');
					mormont('trackClicks', ['article > main']);
								};
		</script>
		<script src="https://cdn.gamer-network.net/2018/scripts/mormont/v2.21.0/mormont.js" async onload="mormontLoaded()"></script>
	<script src="//cdn.gamer-network.net/2018/scripts/edmonds/1.3.1/edmonds.js"></script>
    <script>
      jQuery(document).ready(function() {
          renderEdmonds('.edmonds-block', {
              'site': 'rockpapershotgun.com',
              
          });
      });
    </script>
  <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201830'></script>
<script type='text/javascript' src='https://www.rockpapershotgun.com/wp-includes/js/wp-embed.min.js?ver=4.9.2'></script>
		<script type="text/javascript">
			var bwpRecaptchaCallback = function() {
				// render all collected recaptcha instances
			};
		</script>

		<script src="https://www.google.com/recaptcha/api.js?onload=bwpRecaptchaCallback&#038;render=explicit" async defer></script>
	<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
	<script src="https://cdn.gamer-network.net/plugins/dfp/async.dfp.1.1.21.js"></script>
	<script src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/js/jquery.viewport.js?v2.0.5"></script>
	<script src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/js/ad-related.js?v2.0.5"></script>
	<script src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/js/InlineAds.js?v2.0.5"></script>
	<script src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/js/SidebarAds.js?v2.0.5"></script>
	<script src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/js/js-cookie.js?v2.0.5"></script>
	<script src="https://www.rockpapershotgun.com/wp-content/themes/rps-2018/js/CookieGDPR.js?v2.0.5"></script>



</body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 3169/3426 objects using memcache
Database Caching 59/95 queries in 0.021 seconds using memcache

 Served from: rockpapershotgun.com @ 2018-07-23 22:05:43 by W3 Total Cache -->