<!DOCTYPE html>
<html lang="en">
  <head>
          <meta charset="utf-8">
      <meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=5.0">
      <meta http-equiv="X-UA-Compatible" content="ie=edge">

      <title>Babylon&#39;s Fall combines crispy combat with the Destiny power grind | Rock Paper Shotgun</title>

  <meta property="og:description" content="We got hands-on with the Babylon&#39;s Fall closed beta and found it to be NieR: Automata meets Destiny, with glimmers of potential.">
  <meta property="og:site_name" content="Rock Paper Shotgun">
  <meta property="og:title" content="Babylon&#39;s Fall combines crispy combat with the Destiny power grind">
  <meta property="og:type" content="article">
  <meta property="og:url" content="https://www.rockpapershotgun.com/babylons-fall-combines-crispy-combat-with-the-destiny-power-grind">
  <meta property="og:image" content="https://assets2.rockpapershotgun.com/babylonsfall_ss_04.jpg/BROK/thumbnail/1600x900/format/jpg/quality/80/babylonsfall_ss_04.jpg">
  <meta property="article:published_time" content="2021-11-25T17:00:00+00:00">
  <meta property="article:tag" content="Action">
  <meta property="article:tag" content="RPG">
  <meta property="article:tag" content="Preview">
  <meta property="article:tag" content="Babylon&#39;s Fall">
  <meta property="article:tag" content="Square Enix">
  <meta property="article:tag" content="Platinum Games">

  <meta name="description" content="We got hands-on with the Babylon&#39;s Fall closed beta and found it to be NieR: Automata meets Destiny, with glimmers of potential.">
  <meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:description" content="We got hands-on with the Babylon&#39;s Fall closed beta and found it to be NieR: Automata meets Destiny, with glimmers of potential.">
  <meta name="twitter:image" content="https://assets2.rockpapershotgun.com/babylonsfall_ss_04.jpg/BROK/thumbnail/1600x800/format/jpg/quality/80/babylonsfall_ss_04.jpg">
  <meta name="twitter:title" content="Babylon&#39;s Fall combines crispy combat with the Destiny power grind">
  <meta name="twitter:image:alt" content="A warrior with a large hammer prepares to fight an orc, who has an equally large hammer, in Babylon&#39;s Fall">
  <meta name="twitter:creator" content="@rockpapershot">
  <meta name="twitter:site" content="@rockpapershot">
  <meta name="robots" content="max-image-preview:large">
<link rel="apple-touch-icon" sizes="180x180" href="/static/014f0de91b9411059fdcbaf2e66634bd/icon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/static/014f0de91b9411059fdcbaf2e66634bd/icon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/static/014f0de91b9411059fdcbaf2e66634bd/icon/favicon-16x16.png">
<link rel="mask-icon" href="/static/014f0de91b9411059fdcbaf2e66634bd/icon/safari-pinned-tab.svg" color="#e7387d">
<link rel="shortcut icon" href="/static/014f0de91b9411059fdcbaf2e66634bd/icon/favicon.ico">
<meta name="msapplication-TileColor" content="#e7387d">
<meta name="theme-color" content="#009c7c">
<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "NewsArticle",
    "url": "https://www.rockpapershotgun.com/babylons-fall-combines-crispy-combat-with-the-destiny-power-grind",
    "mainEntityOfPage": "https://www.rockpapershotgun.com/babylons-fall-combines-crispy-combat-with-the-destiny-power-grind",
    "headline": "Babylon's Fall combines crispy combat with the Destiny power grind",
    "inLanguage": "en",
    "articleSection": "Feature",
    "description": "We got hands-on with the Babylon's Fall closed beta and found it to be NieR: Automata meets Destiny, with glimmers of potential.",
    "datePublished": "2021-11-25T17:00:00+00:00",
    "publisher": {
        "@type": "Organization",
        "name": "Rock Paper Shotgun",
        "url": "https://www.rockpapershotgun.com/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://assets2.rockpapershotgun.com/rockpapershotgun-logo-small.png",
            "width": 600,
            "height": 60
        }
    },
    "image": [
        "https://assets2.rockpapershotgun.com/babylonsfall_ss_04.jpg/BROK/thumbnail/1200x1200/quality/100/babylonsfall_ss_04.jpg",
        "https://assets2.rockpapershotgun.com/babylonsfall_ss_04.jpg/BROK/thumbnail/1200x900/quality/100/babylonsfall_ss_04.jpg",
        "https://assets2.rockpapershotgun.com/babylonsfall_ss_04.jpg/BROK/thumbnail/1600x900/quality/100/babylonsfall_ss_04.jpg"
    ],
    "author": [
        {
            "@context": "https://schema.org",
            "@type": "Person",
            "name": "Ed Thorn",
            "jobTitle": "Senior Staff Writer",
            "worksFor": {
                "@type": "Organization",
                "name": "Rock Paper Shotgun",
                "url": "https://www.rockpapershotgun.com"
            },
            "image": "https://assets2.rockpapershotgun.com/edprofpic1cropfinal.png",
            "description": "When Ed's not cracking thugs with bicycles in Yakuza, he's likely swinging a badminton racket in real life. Any genre goes, but he's very into shooters and likes a weighty gun, particularly if they have a chainsaw attached to them. Adores orange and mango squash, unsure about olives.",
            "email": "ed.thorn@rockpapershotgun.com",
            "url": [
                "https://www.rockpapershotgun.com/authors/ed-thorn",
                "https://twitter.com/FromEdward"
            ]
        },
        {
            "@context": "https://schema.org",
            "@type": "Person",
            "name": "Katharine Castle",
            "jobTitle": "Editor-in-chief",
            "worksFor": {
                "@type": "Organization",
                "name": "Rock Paper Shotgun",
                "url": "https://www.rockpapershotgun.com"
            },
            "image": "https://assets2.rockpapershotgun.com/8f8b5433f2bc56a970cc9bb9a0f89755.jpg",
            "description": "Katharine is RPS' editor-in-chief, which means she's now to blame for all this. After joining the team in 2017, she spent a lot of time in the RPS hardware mines, testing all the bits that go inside our PCs, but now she gets to write about all the lovely games we play on them, too. She'll play pretty much anything she can get her hands on, and is very partial to JRPGs and the fetching of quests.",
            "email": "katharine@rockpapershotgun.com",
            "url": [
                "https://www.rockpapershotgun.com/authors/katharine-castle",
                "https://twitter.com/Byrneinator"
            ]
        }
    ],
    "keywords": [
        "Action",
        "RPG",
        "Preview",
        "Babylon's Fall",
        "Square Enix",
        "Platinum Games"
    ]
}
</script>

<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "name": "Home",
            "item": "https://www.rockpapershotgun.com/"
        },
        {
            "@type": "ListItem",
            "position": 2,
            "name": "Features",
            "item": "https://www.rockpapershotgun.com/features"
        },
        {
            "@type": "ListItem",
            "position": 3,
            "name": "Babylon's Fall",
            "item": "https://www.rockpapershotgun.com/games/babylons-fall"
        }
    ]
}
</script>


  <script>
    window.dataLayer = window.dataLayer || [];
    function gtag() { dataLayer.push(arguments); }

    function _appendGoogleAnalytics(anonymous) {
        if (window.gtagDone) return;

        gtag('js', new Date());

        const options = {
    "dimension4": "0",
    "dimension5": "0",
    "dimension1": "features",
    "dimension2": "action,rpg,preview,babylons-fall,square-enix,platinum-games",
    "dimension3": "Ed Thorn",
    "dimension7": "2021-11-25",
    "dimension8": "babylons-fall"
};

        options['link_attribution'] = true;

        if (anonymous) {
          options['client_storage'] = 'none';
          options['store_gac'] = false;
          options['anonymize_ip'] = true;

            gtag('set', 'allow_ad_personalization_signals', false);

          options['dimension6'] = '1';
        } else {
          options['dimension6'] = '0';
        }

        gtag('config', 'UA-2667859-1', options);

          gtag('config', 'AW-1022621291');

        const gaScript = document.createElement('script');
        gaScript.type = 'text/javascript';
        gaScript.async = true;
        gaScript.src = 'https://www.googletagmanager.com/gtag/js?id=UA-2667859-1';

        document.getElementsByTagName('head')[0].appendChild(gaScript);
        window.gtagDone = true;

        window.dispatchEvent(new Event('BrockmanAnalyticsEnabled'));
    }

    function appendGoogleAnalytics() {
      _appendGoogleAnalytics(false);
    }

    function appendGoogleAnalyticsAnonymous() {
      _appendGoogleAnalytics(true);
    }

    window.addEventListener('BrockmanPerformanceCookiesAllowed', appendGoogleAnalytics);
    window.addEventListener('BrockmanPerformanceCookiesDisallowed', appendGoogleAnalyticsAnonymous);
  </script>
  <script>
      window.PARSELY = window.PARSELY || {
        autotrack: false,
        onReady: function() {
          PARSELY.updateDefaults({
            data: {
    "user": "unregistered"
}
          });
          PARSELY.beacon.trackPageView();
        }
      };

    function appendParsely() {
        if (window.parselyDone) return;
        (function(d) {
          var b = d.body;
          var e = d.createElement('script');
          e.id = 'parsely-cfg';
          e.src = '//cdn.parsely.com/keys/rockpapershotgun.com/p.js';
          b.appendChild(e);
        })(document);
        window.parselyDone = true;
    }

    window.addEventListener('BrockmanPerformanceCookiesAllowed', appendParsely);
  </script>
  <script>
    function appendPubStack() {
      if (window.pubStackDone) return;
      const pubStackScript = document.createElement('script');
      pubStackScript.type = 'text/javascript';
      pubStackScript.async = true;
      pubStackScript.src = 'https://boot.pbstck.com/v1/tag/2c628ad2-49f6-47f7-bf72-a603f682566b';
      document.getElementsByTagName('head')[0].appendChild(pubStackScript);
      window.pubStackDone = true;
    }

    window.addEventListener('BrockmanTCFConsent', appendPubStack);
  </script>

  <script>
    window.mainScriptsEvent = document.createEvent('CustomEvent');
    window.mainScriptsEvent.initCustomEvent('mainScripts');
  </script>
  <script defer src="/static/014f0de91b9411059fdcbaf2e66634bd/js/main.min.js" onload="window.dispatchEvent(window.mainScriptsEvent)"></script>

<script>
  window.addEventListener('mainScripts', function() {
    window.BrockmanLazyLoad = new BrockmanLazyLoad();
    window.BrockmanLazyLoad.run();
  });
</script>
<script>
  window.addEventListener('mainScripts', function() {
    window.BrockmanLightbox = new BrockmanLightbox({
      selector: 'a[data-lightbox=true], .article a > img'
    });
    window.BrockmanLightbox.run();
  });
</script>
    <script>
      window.commercialScriptsEvent = document.createEvent('CustomEvent');
      window.commercialScriptsEvent.initCustomEvent('commercialScripts');
    </script>
    <script defer src="/static/014f0de91b9411059fdcbaf2e66634bd/js/commercial.min.js" onload="window.dispatchEvent(window.commercialScriptsEvent)"></script>

  <script>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</script>


  <link rel="preload" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as="script">
  <link rel="preload" href="https://c.amazon-adsystem.com/aax2/apstag.js" as="script">

<script>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</script>
  

  <script>
    function appendBlueBillywig() {
      if (window.blueBillywigDone) return;
      window.BrockmanBlueBillywig = new BrockmanBlueBillywig({
        site: 'rock_paper_shotgun',
        player_id: 'rock_paper_shotgun',
        autoplay_id: 'rock_paper_shotgun_autoplay',
        article_type: 'feature',
        device: 'hd',
        sticky_mobile_id: 'rock_paper_shotgun_autoplay_guide',
        sticky_desktop_id: 'rock_paper_shotgun_autoplay_guide_desktop',
      });
      window.BrockmanBlueBillywig.run();
      window.blueBillywigDone = true;
    }

    window.addEventListener('BrockmanTargetingCookiesAllowed', appendBlueBillywig);
  </script>

  <script>
    function appendCarbon() {
      !function(a,l,b,c,k,s,t,g,A){a.CustomerConnectAnalytics=k,a[k]=a[k]||function(){
      (a[k].q=a[k].q||[]).push(arguments)},g=l.createElement(b),A=l.getElementsByTagName(b)[0],
      g.type="text/javascript",g.async=!0,g.src=c+"?id="+s+"&parentId="+t,A.parentNode.insertBefore(g,A)
      }(window,document,"script","//carbon-cdn.ccgateway.net/script","cca",window.location.hostname,"04d6b31292");
    }
    window.addEventListener('BrockmanTCFConsent', appendCarbon);
  </script>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: '2', c2: '8518622', cs_ucfr: '' });

  function appendComscore(cs_ucfr_value) {
    (self.COMSCORE && COMSCORE.beacon({ c1: "2", c2: "8518622", cs_ucfr: cs_ucfr_value }));
    if (window.comscoreDone) return;
    _comscore[0].cs_ucfr = cs_ucfr_value;
    const s = document.createElement("script");
    const el = document.getElementsByTagName("script")[0];
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://sb.scorecardresearch.com/cs/8518622/beacon.js';
    el.parentNode.insertBefore(s, el);
    window.comscoreDone = true;
  }

  window.addEventListener('BrockmanTargetingCookiesDisallowed', () => appendComscore(0));
  window.addEventListener('BrockmanTargetingCookiesAllowed', () => appendComscore(1));
</script>


  <script>
    function appendSkimlinks() {
      if (window.skimlinksDone) return;
      const skimlinksScript = document.createElement('script');
      skimlinksScript.type = 'text/javascript';
      skimlinksScript.async = true;
      skimlinksScript.src = 'https://s.skimresources.com/js/87431X1560958.skimlinks.js';
      document.getElementsByTagName('head')[0].appendChild(skimlinksScript);
      window.skimlinksDone = true;
    }

    window.addEventListener('BrockmanTargetingCookiesAllowed', appendSkimlinks);
  </script>

  <script>
    function appendFacebookPixels() {
      if (window.facebookPixelsDone) return;
      !function(f,b,e,v,n,t,s)
      {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
      n.callMethod.apply(n,arguments):n.queue.push(arguments)};
      if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
      n.queue=[];t=b.createElement(e);t.async=!0;
      t.src=v;s=b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t,s)}(window, document,'script',
      'https://connect.facebook.net/en_US/fbevents.js');

        fbq('init', '700623604017080');

      fbq('track', 'PageView');
      window.facebookPixelsDone = true;

      window.dispatchEvent(new Event('BrockmanFacebookPixelsEnabled'));
    }

    window.addEventListener('BrockmanTargetingCookiesAllowed', appendFacebookPixels);
  </script>


    <script>
      window.articleScriptsEvent = document.createEvent('CustomEvent');
      window.articleScriptsEvent.initCustomEvent('articleScripts');
    </script>
    <script defer src="/static/014f0de91b9411059fdcbaf2e66634bd/js/article.min.js" onload="window.dispatchEvent(window.articleScriptsEvent)"></script>

  <script>
    window.addEventListener('articleScripts', function() {
      window.BrockmanEdmonds = new BrockmanEdmonds({
        selector: '.edmonds-block',
        site: 'rockpapershotgun.com',
        edmonds_url: 'https://edmonds.gamer-network.net',
      });
      window.BrockmanEdmonds.run();
    });
  </script>

  <script>
    window.addEventListener('articleScripts', () => {
      window.BrockmanComments = new BrockmanComments({
          id: '/community/thread/1e7y7',
          postCount: '3',
      });
    });
  </script>


<script>
  window.addEventListener('DOMContentLoaded', () => {
    Array.prototype.slice.call(
      document.querySelectorAll('.article .spoiler')
    ).forEach(spoiler => {
      spoiler.onclick = e => e.target.classList.toggle('active');
      spoiler.title = 'Spoiler';
    });
  });
</script>
<script>
  function stripBBWStyling(el) {
    function waitForElement() {
      return new Promise((resolve) => {
        if (checkChildren(el?.parentElement?.children)) {
          return resolve();
        }

        const observer = new MutationObserver((mutations) => {
          if (checkChildren(el?.parentElement?.children)) {
            resolve();
            observer.disconnect();
          }
        });

        observer.observe(top.document.body, {
          childList: true,
          subtree: true,
        });
      });
    }

    function checkChildren (children) {
      for (let i = 0; i < children?.length; i++) {
        if (children[i].classList.contains("bb_iawr")) return true
      }
    }

    waitForElement().then(() => {
      el.nextSibling.style.cssText = "position: absolute; top: 0; height: 100%; width: 100%; margin: 0;";
    });
  }
</script>  <script defer src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="f6950cfb-6f09-4e7d-8fdf-3415107ca910"></script>

<script>
  function enableElements() {
    const elements = document.querySelectorAll('iframe[data-src], script[data-src]');
    for (let i = 0; i < elements.length; i ++) {
      const element = elements[i];
      element.setAttribute('src', element.dataset.src);
    }
  }

  function showEmbedPlaceholders() {
    if (window.embedPlaceholdersDone) return;
    const elements = document.querySelectorAll('.embed_placeholder');
    for (let i = 0; i < elements.length; i ++) {
      const element = elements[i];
      element.style.display = '';
    }
    window.embedPlaceholdersDone = true;
  }

  function hideTargetingEmbedPlaceholders() {
    hideEmbedPlaceholders('targeting');
  }

  function hidePerformanceEmbedPlaceholders() {
    hideEmbedPlaceholders('performance');
  }

  function hideEmbedPlaceholders(type) {
    const identifier = '.embed_placeholder' + (type ? '[data-type="' + type + '"]' : '');
    const elements = document.querySelectorAll(identifier);
    for (let i = 0; i < elements.length; i ++) {
      const element = elements[i];
      element.style.display = 'none';
    }
  }

  function performanceCookiesAllowed() {
    window.dispatchEvent(new Event('BrockmanPerformanceCookiesAllowed'));
    hidePerformanceEmbedPlaceholders();
  }

  function performanceCookiesDisallowed() {
    window.dispatchEvent(new Event('BrockmanPerformanceCookiesDisallowed'));
  }

  function targetingCookiesAllowed() {
    window.dispatchEvent(new Event('BrockmanTargetingCookiesAllowed'));
    enableElements();
    hideTargetingEmbedPlaceholders();
  }

  function targetingCookiesDisallowed() {
    window.dispatchEvent(new Event('BrockmanTargetingCookiesDisallowed'));
  }


    function OptanonWrapper() {
        window.BrockmanAllowedCookies = {
          performance: OptanonActiveGroups.match(/,2,/) !== null,
          targeting: OptanonActiveGroups.match(/,4,/) !== null,
        };

        showEmbedPlaceholders();

        window.BrockmanAllowedCookies.performance ?
          performanceCookiesAllowed() : performanceCookiesDisallowed();

        window.BrockmanAllowedCookies.targeting ?
          targetingCookiesAllowed() : targetingCookiesDisallowed();

        window.dispatchEvent(new Event('BrockmanLoadAds'));
    }
</script>
  <style>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</style>

        <link rel="canonical" href="https://www.rockpapershotgun.com/babylons-fall-combines-crispy-combat-with-the-destiny-power-grind">

      <link rel="alternate" type="application/rss+xml" href="/feed">



  <script>
    function appendApester() {
      if (window.apesterDone) return;

      const apesterScript = document.createElement('script');
      apesterScript.async = true;
      apesterScript.src = '//static.apester.com/js/sdk/v2.0/apester-javascript-sdk.min.js';
      document.getElementsByTagName('head')[0].appendChild(apesterScript);

      window.apesterDone = true;
    }

    window.addEventListener('BrockmanTargetingCookiesAllowed', appendApester);
  </script>
  </head>
  <body
      data-version="hd"
      data-page="article"
      data-ads="true"
      data-affiliates="true"
      data-menu="false"
  >
    <div id="app_wrapper">
        <header class="app_header">


  <nav class="nav_trending">

        <ul>
                  <li>
                    <a
                      href="https://www.rockpapershotgun.com/best-new-world-character-builds"
                      data-active="false"
                      
                    >
                        Best New World builds
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.rockpapershotgun.com/minecraft-1-18-release-date-caves-and-cliffs-part-2-update"
                      data-active="false"
                      
                    >
                        Minecraft 1.18
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.rockpapershotgun.com/genshin-impact-banners"
                      data-active="false"
                      
                    >
                        Next Genshin Impact banner
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.rockpapershotgun.com/call-of-duty-vanguard-best-guns"
                      data-active="false"
                      
                    >
                        Call Of Duty: Vanguard best guns
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.rockpapershotgun.com/early-black-friday-2021-gaming-mouse-keyboards"
                      data-active="false"
                      
                    >
                        Black Friday Mouse and Keyboard Deals
                    </a>
                  </li>
        </ul>
  </nav>
  <nav class="nav_main">


<a
  href="/"
  class="logo"
  
>
    <img src="https://assets2.rockpapershotgun.com/0275_rockpapershotgun-logo.svg" alt="Rock Paper Shotgun logo" loading="eager">
</a>


  <nav class="nav_primary">
        

        <ul>
                  <li>
                    <a
                      href="/latest"
                      data-active="false"
                      
                    >
                        Latest
                    </a>
                  </li>
                  <li>
                    <a
                      href="/news"
                      data-active="false"
                      
                    >
                        News
                    </a>
                  </li>
                  <li>
                    <a
                      href="/reviews"
                      data-active="false"
                      
                    >
                        Reviews
                    </a>
                  </li>
                  <li>
                    <a
                      href="/hardware"
                      data-active="false"
                      
                    >
                        Hardware
                    </a>
                  </li>
                  <li>
                    <a
                      href="/features"
                      data-active="false"
                      
                    >
                        Features
                    </a>
                  </li>
                  <li>
                    <a
                      href="/videos"
                      data-active="false"
                      
                    >
                        Videos
                    </a>
                  </li>
                  <li>
                    <a
                      href="/guides"
                      data-active="false"
                      
                    >
                        Guides
                    </a>
                  </li>
        </ul>
  </nav>



  <nav class="nav_secondary">
        

        <ul>
                  <li>
                    <a
                      href="/topics/bestest-bests"
                      data-active="false"
                      
                    >
                        Bestest Bests
                    </a>
                  </li>
                  <li>
                    <a
                      href="/topics/free-games"
                      data-active="false"
                      
                    >
                        Free games
                    </a>
                  </li>
                  <li>
                    <a
                      href="/supporters"
                      data-active="false"
                      
                    >
                        Supporters
                    </a>
                  </li>
                  <li>
                    <a
                      href="/topics/black-friday"
                      data-active="false"
                      
                    >
                        Black Friday
                    </a>
                  </li>
                  <li>
                    <a
                      href="/podcasts"
                      data-active="false"
                      
                    >
                        Podcasts
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://discord.gg/rockpapershotgun"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Discord
                    </a>
                  </li>
        </ul>
  </nav>

<div class="commercial button_group">
  <a href="/subscribe" class="button supporter">
    Support us
  </a>

  <a href="/newsletter" class="button newsletter">
    Join our newsletter
  </a>

  <a
    href="https://store.reedpop.com/collections/rock-paper-shotgun"
    target="_blank"
    rel="noopener"
    class="button store"
  >
    Visit our store
  </a>
</div>
      <div class="actions">
  <form class="search_box" action="/search">
    <input type="text" name="q" aria-label="Search" placeholder="Search">
  </form>

  <div class="user_profile signed_out">
    <div class="button_group">
      <a class="button small login" href="/community/auth/start?next=/babylons-fall-combines-crispy-combat-with-the-destiny-power-grind" rel="nofollow">Sign in / Create account</a>
    </div>
  </div>
      </div>
  </nav>
        </header>

        <main id="page_wrapper">
  <div class="advert_container leaderboard_container">
    <div class="advert leaderboard"
      data-dfp-id="RPS_LB_1"
      data-dfp-sizes="300x250, 320x50, 728x90, 960x160, 960x250, 970x250, 1260x110, 1260x160, 1260x200, 1260x250"
      data-dfp-targeting="site=rockpapershotgun.com"
      id="RPS_LB_1_1"
    ></div>
  </div>

              <div id="content">
  <div id="content_above">
        <div class="page_content">


<p class="alert info discount_alert">
  Save 35% on a
    <a href="/subscribe">Rock Paper Shotgun yearly subscription</a>
  this Black Friday!
</p>    <div class="disclaimer">
    If you click on a link and make a purchase we may receive a small commission.
    <a href="/editorial-policy">Read our editorial policy</a>.
  </div>

  <article
    class="article "
data-ads="true"
data-article-type="features"
data-paywalled="false"
data-premium="false"
data-type="article"  >

<header class="article_header">
  <div class="breadcrumbs">
  

  <nav class="nav_breadcrumbs">
        

        <ul>
                  <li>
                    <a
                      href="/"
                      data-active="false"
                      
                    >
                        Home
                    </a>
                  </li>
                  <li>
                    <a
                      href="/features"
                      data-active="false"
                      
                    >
                        Features
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games/babylons-fall"
                      data-active="false"
                      
                    >
                        Babylon&#39;s Fall
                    </a>
                  </li>
        </ul>
  </nav>

  <div class="summary">
  <p class="comments">
      <a href="https://www.rockpapershotgun.com/babylons-fall-combines-crispy-combat-with-the-destiny-power-grind#comments">
    3
      </a>
  </p>
  </div>
  </div>

    <div class="details">
        <h1 class="title">    Babylon&#39;s Fall combines crispy combat with the Destiny power&nbsp;grind
</h1>

        <span class="strapline">But questions remain around progression</span>
    </div>

    <div class="metadata">

<div class="avatar">
  <img
    src="https://assets2.rockpapershotgun.com/edprofpic1cropfinal.png/BROK/thumbnail/70x70/quality/60/edprofpic1cropfinal.png"
    srcset="https://assets2.rockpapershotgun.com/edprofpic1cropfinal.png/BROK/thumbnail/70x70/quality/60/edprofpic1cropfinal.png 1x, https://assets2.rockpapershotgun.com/edprofpic1cropfinal.png/BROK/thumbnail/140x140/quality/60/edprofpic1cropfinal.png 2x"
loading="lazy"    class="avatar_image"
    alt="Ed Thorn avatar"
width="70"height="70"  >
</div>
        <div class="author">
              <span class="article_type" data-slug="features">
                Feature
              </span>

              <span class="by">by</span>
              <span class="name">
                  <a href="/authors/ed-thorn">Ed Thorn</a>
              </span>

                <span class="job_title">
                    Senior Staff Writer
                </span>
        </div>

        <div class="additional_authors">
          <span class="by">Additional contributions by</span>
          <ul>
              <li class="name">
                  <a href="/authors/katharine-castle">Katharine Castle</a>
              </li>
          </ul>
        </div>


        <div class="published_at">
          Published on
          <time datetime="2021-11-25 17:00:00+00:00">
            25 Nov, 2021
          </time>
        </div>

    </div>





<div class="headline_asset">
  <figure class="headline_image_wrapper">
  <a
    href="https://assets2.rockpapershotgun.com/babylonsfall_ss_04.jpg/BROK/resize/1920x1920%3E/format/jpg/quality/80/babylonsfall_ss_04.jpg"
    target="_blank"
    data-lightbox="true"
  >
  <img
    src="https://assets2.rockpapershotgun.com/babylonsfall_ss_04.jpg/BROK/resize/880%3E/format/jpg/quality/80/babylonsfall_ss_04.jpg"
    srcset="https://assets2.rockpapershotgun.com/babylonsfall_ss_04.jpg/BROK/resize/880%3E/format/jpg/quality/80/babylonsfall_ss_04.jpg 1x, https://assets2.rockpapershotgun.com/babylonsfall_ss_04.jpg/BROK/resize/1760%3E/format/jpg/quality/80/babylonsfall_ss_04.jpg 2x"
loading="eager"    class="headline_image"
    alt="A warrior with a large hammer prepares to fight an orc, who has an equally large hammer, in Babylon&#39;s Fall"
width="880"height="495"  >
  </a>

  </figure>
</div>
</header>    <div class="article_body">
        <div class="article_body_content">
          <p>Katharine and I went hands-on with <a href="https://www.rockpapershotgun.com/games/babylons-fall">Babylon&rsquo;s Fall</a> last week, that online action RPG by PlatinumGames which falls in and out of memory as the years tick by. Still, when an invitation to the third phase of its ongoing closed beta test arrived, I couldn&rsquo;t help but get excited. These are the folks behind <a href="https://www.rockpapershotgun.com/games/nier-automata">NieR: Automata</a> and <a href="https://www.rockpapershotgun.com/games/metal-gear-rising-revengeance">Metal Gear Rising: Revengeance</a>, after all, and now they&rsquo;re making a live-service, co-op slasher. Sign. Me. Up.</p>
<p>As it stands, the closed beta only showed a very small, very early build of the game, but we&rsquo;ve got some thoughts. Combat, exploration, and co-op were all on offer here, and there&rsquo;s a fair amount to unpack. Look beyond the early build jank and there&rsquo;s definitely potential.</p>
<!--more-->
<div class="blue_billywig">
<figure class="video_wrapper bluebillywig">
<script async data-cookies-src="https://gamernetwork.bbvms.com/p/rock_paper_shotgun_autoplay/c/4254613.js" data-lazyload="true" data-nocookies-src="https://gamernetwork.bbvms.com/p/rock_paper_shotgun_no_cookies/c/4254613.js" onload="stripBBWStyling(this)"></script>
</figure>
<a class="button" href="https://www.youtube.com/watch?v=tRX3EqCyB1c" rel="noopener" target="_blank">
        Watch on YouTube
    </a>
</div>
<p>You may not be well acquainted with Babylon&rsquo;s Fall, so here&rsquo;s the lowdown. Set in a fantasy world with an oil-painting aesthetic, this is NieR: Automata meets <a href="https://www.rockpapershotgun.com/games/destiny-2">Destiny</a>. You play as a warrior known as a Sentinel tasked with overcoming the Tower Of Babylon. There&rsquo;s lots of hacking, lots of slashing, and copious amounts of looting. Not forgetting your Gideon Coffin, which is a funny name for what&rsquo;s essentially two floating weapons on your back. More on this in a sec.</p>
<p>In this build, we were able to create a character out of three races: Huysian, Agavian, and Geleilion. Right now, there&rsquo;s not much to differentiate them beyond their starting weapon type. I opted for the sword-based Huysian because they looked like a <a href="https://www.rockpapershotgun.com/games/dishonored-2">Dishonored</a> NPC at a masquerade ball; snooty but elegant. Katharine went for the forest-dwelling archer Geleilion, mostly because their bird-like feather costume looked a lot more exciting than the boring grey armour of the hammer Agavian man, but in the end we needn&rsquo;t have worried about their looks, as both our characters ended up wearing the same starter armour. </p>
<p>The Geleilion did have one extra trick up their fake feathery sleeves, though, and that was two Gideon Coffin abilities rather than one. My refined-boy had &ldquo;Soul Vault&rdquo;, which would&rsquo;ve allowed me to fling myself in the direction of a tethered enemy had they been unlockable in this build, while Katharine had &ldquo;Soul Snatch&rdquo; (which would have let her absorb HP from tethered enemies) and &ldquo;Soul Corrupt&rdquo; (an ability that channels dark energy into souls of tethered foes to weaken them over time).</p>
<figure>
<a data-lightbox="true" href="https://assets2.rockpapershotgun.com/babylons-fall-hub-robo-pal.jpg/BROK/resize/1920x1920%3E/format/jpg/quality/80/babylons-fall-hub-robo-pal.jpg" target="_blank">
<img alt="A woman stands in a medieval marketplace next to a merchant named Pymaglion and his floating robot pal in Babylon's Fall" class="content_image" height="388" loading="lazy" src="https://assets2.rockpapershotgun.com/babylons-fall-hub-robo-pal.jpg/BROK/resize/690%3E/format/jpg/quality/80/babylons-fall-hub-robo-pal.jpg" srcset="https://assets2.rockpapershotgun.com/babylons-fall-hub-robo-pal.jpg/BROK/resize/690%3E/format/jpg/quality/80/babylons-fall-hub-robo-pal.jpg 1x, https://assets2.rockpapershotgun.com/babylons-fall-hub-robo-pal.jpg/BROK/resize/1380%3E/format/jpg/quality/80/babylons-fall-hub-robo-pal.jpg 2x" width="690"></a>
<figcaption>One of the vendors has this fun little robo-boy companion that floats around with its wiggly arms. We were both fans.</figcaption>
</figure>
<p>Once we&rsquo;d picked our Sentinels, we were popped in a hub space, akin to something like Destiny&rsquo;s Tower where you can see fellow players running about. It&rsquo;s here where you&rsquo;ll trade with NPCs and take on missions from the Quest boards. A blacksmith clanks his hammer and some guards block towering gates. There&rsquo;s a sense you'll eventually be able to alter gear and upgrade your Gideon Coffins here, as well as venture out into other parts of the town in some way, but again, we&rsquo;ll have to wait and see how that develops in a future test.</p>
<p>In this phase of the beta, we got to sample one type of quest from the &ldquo;Civic Cloister&rdquo; section of the Tower Of Babylon, which whisked us away into a baroque-style dungeon split into multiple &ldquo;chapters&rdquo; - effectively increasingly difficult arenas filled with waves of enemies. Your job? Slash lots of goblins with shields and lanky archers and podgy fire-bombers to advance. Often, there would be a big boss at the end. Sometimes these would just be bigger versions of monsters we&rsquo;d seen before, but others, such as the hammer-swinging &ldquo;Igigi Warlord&rdquo; were more bespoke. The latter entered an enraged state every so often, and we&rsquo;d have to drain a separate stagger bar to stun him before we could go back to whaling on his health. </p>
<p>As expected, fights had that crispy Platinum feel &ndash; only here you can wield up to four weapons of your choice at a time. You've got one for light attacks and one for heavy attacks, both of which can be mixed and matched. Bow, staff, hammer, sword. Whatever takes your fancy. These are then coupled with your two Gideon Arms on the left and right triggers of your gamepad (keyboard controls weren&rsquo;t supported in this build), which let you wear a pair of weapons as these magic, floaty appendages strapped to your back. The result is combat that&rsquo;s a give and take relationship. Strike enemies with your basic light and heavy combos to feed your &ldquo;Spirit&rdquo; meter, which in turn lets you dodge and use your Gideon Arms to deal even <em>more</em> damage.</p>
<figure class="right">
<a data-lightbox="true" href="https://assets2.rockpapershotgun.com/babylons-fall-igigi-warlord.jpg/BROK/resize/1920x1920%3E/format/jpg/quality/80/babylons-fall-igigi-warlord.jpg" target="_blank">
<img alt="Warriors fight a large orc in Babylon's Fall" class="content_image" height="388" loading="lazy" src="https://assets2.rockpapershotgun.com/babylons-fall-igigi-warlord.jpg/BROK/resize/690%3E/format/jpg/quality/80/babylons-fall-igigi-warlord.jpg" srcset="https://assets2.rockpapershotgun.com/babylons-fall-igigi-warlord.jpg/BROK/resize/690%3E/format/jpg/quality/80/babylons-fall-igigi-warlord.jpg 1x, https://assets2.rockpapershotgun.com/babylons-fall-igigi-warlord.jpg/BROK/resize/1380%3E/format/jpg/quality/80/babylons-fall-igigi-warlord.jpg 2x" width="690"></a>
<figcaption>Lock onto targets and it'll produce this diamond symbol. Sometimes a little red indicator will appear on its left side, sometimes on the right, sometimes on both. For the life of the me, I couldn't figure out how it worked.</figcaption>
</figure>
<p>Combat is fast and fluid, and with four weapons in tow, combos look super cool. With melee weapons, it&rsquo;s the sort of combat that feels crunchy and stylish. Button combos aren&rsquo;t particularly complicated &ndash; if you&rsquo;ve played a Platinum game before, Babylon&rsquo;s Fall uses that familiar mix of following up light attacks with strong ones, and then whacking a fancy Gideon Arm finisher on the end. It's nowhere near as intricate as <a href="https://www.rockpapershotgun.com/games/devil-may-cry-5">Devil May Cry 5</a>, say (try as we might, there was no effective way to launch enemies skyward, for example) but it&rsquo;s definitely a step up from the automated throes of <a href="https://www.rockpapershotgun.com/games/final-fantasy-xv">Final Fantasy XV</a>. </p>
<p>Opt for a ranged weapon, though, and it&rsquo;s a different story. I found the magic staff cumbersome and dull, with a reliance on repetitive orb-slings and not much else to draw upon. Katharine didn&rsquo;t have many positive things to say about the bow, either &ndash; especially when her first mission lumped her with four of the poxy things. They&rsquo;re a decent choice when mixed with swords and hammers, but on their own they devolve into a lot of tedious backpedaling while slinging equally repetitive arrows into oncoming monster skulls. </p>
<p>But hey, the Gideon Arms are fun. Activate these and depending on what you&rsquo;ve got equipped, you&rsquo;ll see a spectral sword slash your enemies or a staff unleash an enormous magic missile. The hammer proved to be deeply satisfying, as holding down the trigger let me wind up massive blow that could knock multiple foes to the ground and leave them vulnerable to attack.</p>
<figure>
<a data-lightbox="true" href="https://assets2.rockpapershotgun.com/babylons-fall-street.jpg/BROK/resize/1920x1920%3E/format/jpg/quality/80/babylons-fall-street.jpg" target="_blank">
<img alt="A warrior stands on a stone bridge in Babylon's Fall" class="content_image" height="388" loading="lazy" src="https://assets2.rockpapershotgun.com/babylons-fall-street.jpg/BROK/resize/690%3E/format/jpg/quality/80/babylons-fall-street.jpg" srcset="https://assets2.rockpapershotgun.com/babylons-fall-street.jpg/BROK/resize/690%3E/format/jpg/quality/80/babylons-fall-street.jpg 1x, https://assets2.rockpapershotgun.com/babylons-fall-street.jpg/BROK/resize/1380%3E/format/jpg/quality/80/babylons-fall-street.jpg 2x" width="690"></a>
<figcaption>Babylon's Fall has some excellent vistas. Look closely and you'll see brush strokes, as if the sky's been painted on canvas. In-between fights, it really does make you stop and sink the views in.</figcaption>
</figure>
<p>I wouldn&rsquo;t say there was much strategy involved in these fights, though. No matter how I sliced and diced, so long as I kept doing so I'd pull through. And what awaited me? More of the same, just harder. You see, Babylon&rsquo;s Fall does the Destiny thing where you&rsquo;ve got a character level and a power level. The former is determined by the EXP you earn in battle, while the latter goes up or down dependent on the gear you&rsquo;ve got equipped. Tougher encounters in the Civic Cloister require higher power levels, so you need to grind these out by completing lower ranked quests.</p>
<p>Thankfully loot drops seemed pretty generous in our time with Babylon&rsquo;s Fall. Complete Chapters and you&rsquo;d earn Relics of different rarities. At the end of each quest, you&rsquo;d crack them open, earn sweet gear and in turn become more powerful. Much like the combat, armour sets and weapons also looked very snazzy, indeed. There&rsquo;s a fair amount of stats to absorb too, like boosts to Spirit regeneration, health, and so on. I&rsquo;d imagine that these will play a bigger role in the full game, where team composition may matter more.</p>
<p>While it was a slim taster of what's to come, Babylon's Fall shows signs of promise. Questions remain around progression and whether there will be plentiful ways to grind out those levels, aside from clambering up the Civic Cloister repeatedly. And of course, how they'll handle endgame stuff when folks have hit the level cap. But overall, I'd say we had a fairly good time. A tentative thumbs up from us, then, and fingers crossed the devs successfully spin this crunchy combat core into a moreish dungeon crawler.</p>
        </div>



    </div>
  </article>

<footer class="article_footer">
    <div class="tagged_with">
      <h2 class="section_title small">Tagged With</h2>
    <ul>
        <li>
          <a href="/games/babylons-fall">Babylon&#39;s Fall</a>
        </li>
        <li>
          <a href="/topics/platinum-games">Platinum Games</a>
        </li>
        <li>
          <a href="/topics/preview">Preview</a>
        </li>
        <li>
          <a href="/topics/square-enix">Square Enix</a>
        </li>
    </ul>
  </div>

    <div class="author_bio compact">
      <h2 class="section_title small">About the Author</h2>





<article class="summary" data-type="persona">
    <a
      href="/authors/ed-thorn"
      class="link_overlay"
      title="Ed Thorn"
    ></a>

<div class="avatar">
  <img
    src="https://assets2.rockpapershotgun.com/edprofpic1cropfinal.png/BROK/thumbnail/70x70/quality/60/edprofpic1cropfinal.png"
    srcset="https://assets2.rockpapershotgun.com/edprofpic1cropfinal.png/BROK/thumbnail/70x70/quality/60/edprofpic1cropfinal.png 1x, https://assets2.rockpapershotgun.com/edprofpic1cropfinal.png/BROK/thumbnail/140x140/quality/60/edprofpic1cropfinal.png 2x"
loading="lazy"    class="avatar_image"
    alt="Ed Thorn avatar"
width="70"height="70"  >
</div>
  <div class="details">
        <p class="name">
            <a href="/authors/ed-thorn">Ed Thorn</a>
        </p>

      <p class="job_title">
        Senior Staff Writer
      </p>


        <p class="bio">
          When Ed's not cracking thugs with bicycles in Yakuza, he's likely swinging a badminton racket in real life. Any genre goes, but he's very into shooters and likes a weighty gun, particularly if they have a chainsaw attached to them. Adores orange and mango squash, unsure about olives.
        </p>
  </div>
</article>  </div>




<div class="supporters_promo" data-supporter="false">
  <h3>Support Rock Paper Shotgun</h3>
  <p>Subscribe and get access to supporter-only articles, an ad-free reading experience, free gifts, and game discounts. Your support helps us create more great writing about PC games.</p>
  <a class="button" href="/subscribe">See more information</a>
</div>
<div id="comments">
  <div class="container"></div>

  <noscript>
    <p class="alert error">
      Please enable JavaScript to see comments.
    </p>
  </noscript>
</div>
</footer>
      </div>


  <aside class="sidebar">
  <div class="advert_container halfpage_container">
    <div class="advert mpu"
      data-dfp-id="RPS_HP"
      data-dfp-sizes="300x600, 300x250, 300x1050"
      data-dfp-targeting="site=rockpapershotgun.com"
      id="RPS_HP_1"
        data-dfp-collapse="true"
    ></div>
  </div>

      <div class="gn_sidebar"></div>
  </aside>
  </div>

  <div id="content_below">
      <div class="page_content">

    <div class="advert_container low_leaderboard_container">
    <div class="lazyload low_leaderboard"
      data-dfp-id="RPS_LB_2"
      data-dfp-sizes="300x250, 320x50, 728x90, 960x160, 960x250, 970x250, 1200x500"
      data-dfp-targeting="site=rockpapershotgun.com"
      id="RPS_LB_2_AFTER_ARTICLE"
        data-dfp-collapse="true"
    ></div>
  </div>




  <section class="shelf">
        <h2 class="section_title">
      More Features
    </h2>






    <ul class="summary_items">

        <li>




<article
  class="summary"
  data-type="article"
  data-article-type="features"
  data-premium="true"
  data-size="small"
>
    <a href="https://www.rockpapershotgun.com/multiplayer-games-need-to-capture-nods-and-smiles" class="link_overlay" title="Multiplayer games need to capture nods and smiles" ></a>

    <span class="symbol"></span>
    


<div class="thumbnail">
  <img
    src="https://assets2.rockpapershotgun.com/final-fantasy-xiv-ishgardian-greeting.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/final-fantasy-xiv-ishgardian-greeting.jpg"
    srcset="https://assets2.rockpapershotgun.com/final-fantasy-xiv-ishgardian-greeting.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/final-fantasy-xiv-ishgardian-greeting.jpg 1x, https://assets2.rockpapershotgun.com/final-fantasy-xiv-ishgardian-greeting.jpg/BROK/thumbnail/550x310/format/jpg/quality/80/final-fantasy-xiv-ishgardian-greeting.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for Multiplayer games need to capture nods and smiles"
width="275"height="155"  >
</div>

  <div class="wrapper">
        <div class="details">


          <p class="title">
<a href="https://www.rockpapershotgun.com/multiplayer-games-need-to-capture-nods-and-smiles" >  Multiplayer games need to capture nods and smiles
</a>          </p>

            <p class="strapline">Smile and wave</p>
    </div>


    <div class="metadata">
    <span class="author">Ed Thorn</span>

    <time class="published_at" datetime="2021-11-25 15:30:00+00:00">
        7 hours ago

    </time>

  <p class="comments">
      <a href="https://www.rockpapershotgun.com/multiplayer-games-need-to-capture-nods-and-smiles#comments">
    6
      </a>
  </p>
    </div>

    
  </div>
</article>        </li>

        <li>




<article
  class="summary"
  data-type="article"
  data-article-type="features"
  data-premium="false"
  data-size="small"
>
    <a href="https://www.rockpapershotgun.com/halo-infinites-multiplayer-is-the-most-stable-fps-ive-played-all-year" class="link_overlay" title="Halo Infinite&#39;s multiplayer is the most stable FPS I&#39;ve played all year" ></a>

    <span class="symbol"></span>
    


<div class="thumbnail">
  <img
    src="https://assets2.rockpapershotgun.com/halo-infinite-multiplayer_LRsSBln.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/halo-infinite-multiplayer_LRsSBln.jpg"
    srcset="https://assets2.rockpapershotgun.com/halo-infinite-multiplayer_LRsSBln.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/halo-infinite-multiplayer_LRsSBln.jpg 1x, https://assets2.rockpapershotgun.com/halo-infinite-multiplayer_LRsSBln.jpg/BROK/thumbnail/550x310/format/jpg/quality/80/halo-infinite-multiplayer_LRsSBln.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="CTF action in a Halo Infinite multiplayer screenshot."
width="275"height="155"  >
</div>

  <div class="wrapper">
        <div class="details">


          <p class="title">
<a href="https://www.rockpapershotgun.com/halo-infinites-multiplayer-is-the-most-stable-fps-ive-played-all-year" >  Halo Infinite&#39;s multiplayer is the most stable FPS I&#39;ve played all year
</a>          </p>

            <p class="strapline">Running rings around them</p>
    </div>


    <div class="metadata">
    <span class="author">Ed Thorn</span>

    <time class="published_at" datetime="2021-11-24 17:00:00+00:00">
        1 day ago

    </time>

  <p class="comments">
      <a href="https://www.rockpapershotgun.com/halo-infinites-multiplayer-is-the-most-stable-fps-ive-played-all-year#comments">
    5
      </a>
  </p>
    </div>

    
  </div>
</article>        </li>

        <li>




<article
  class="summary"
  data-type="article"
  data-article-type="features"
  data-premium="false"
  data-size="small"
>
    <a href="https://www.rockpapershotgun.com/how-men-of-war-ii-aims-to-reshape-the-frontlines-of-world-war-ii-strategy" class="link_overlay" title="How Men Of War II aims to reshape the frontlines of World War II strategy" ></a>

    <span class="symbol"></span>
    


<div class="thumbnail">
  <img
    src="https://assets2.rockpapershotgun.com/men-of-war-2-logo-art.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/men-of-war-2-logo-art.jpg"
    srcset="https://assets2.rockpapershotgun.com/men-of-war-2-logo-art.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/men-of-war-2-logo-art.jpg 1x, https://assets2.rockpapershotgun.com/men-of-war-2-logo-art.jpg/BROK/thumbnail/550x310/format/jpg/quality/80/men-of-war-2-logo-art.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Artwork for Men of War II, showing tanks, planes and infantry soldiers in an explosive battlefield"
width="275"height="155"  >
</div>

  <div class="wrapper">
        <div class="details">


          <p class="title">
<a href="https://www.rockpapershotgun.com/how-men-of-war-ii-aims-to-reshape-the-frontlines-of-world-war-ii-strategy" >  How Men Of War II aims to reshape the frontlines of World War II strategy
</a>          </p>

            <p class="strapline">Developer Best Way promises a new take on gaming&#39;s favourite war</p>
    </div>


    <div class="metadata">
    <span class="author">Rick Lane</span>

    <time class="published_at" datetime="2021-11-23 22:45:00+00:00">
        2 days ago

    </time>

  <p class="comments">
      <a href="https://www.rockpapershotgun.com/how-men-of-war-ii-aims-to-reshape-the-frontlines-of-world-war-ii-strategy#comments">
    31
      </a>
  </p>
    </div>

    
  </div>
</article>        </li>

        <li>




<article
  class="summary"
  data-type="article"
  data-article-type="features"
  data-premium="false"
  data-size="small"
>
    <a href="https://www.rockpapershotgun.com/what-are-we-all-buying-this-black-friday" class="link_overlay" title="What are we all buying this Black Friday?" ></a>

    <span class="symbol"></span>
    


<div class="thumbnail">
  <img
    src="https://assets2.rockpapershotgun.com/guardians-of-the-galaxy-disabler.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/guardians-of-the-galaxy-disabler.jpg"
    srcset="https://assets2.rockpapershotgun.com/guardians-of-the-galaxy-disabler.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/guardians-of-the-galaxy-disabler.jpg 1x, https://assets2.rockpapershotgun.com/guardians-of-the-galaxy-disabler.jpg/BROK/thumbnail/550x310/format/jpg/quality/80/guardians-of-the-galaxy-disabler.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Star-Lord at merchant stall deciding whether to buy a disabler"
width="275"height="155"  >
</div>

  <div class="wrapper">
        <div class="details">


          <p class="title">
<a href="https://www.rockpapershotgun.com/what-are-we-all-buying-this-black-friday" >  What are we all buying this Black Friday?
</a>          </p>

            <p class="strapline">If anything</p>
    </div>


    <div class="metadata">
    <span class="author">James Archer</span>

    <time class="published_at" datetime="2021-11-23 17:12:53.306904+00:00">
        2 days ago

    </time>

  <p class="comments">
      <a href="https://www.rockpapershotgun.com/what-are-we-all-buying-this-black-friday#comments">
    66
      </a>
  </p>
    </div>

    
  </div>
</article>        </li>
    </ul>


  </section>


  <section class="shelf">
        <h2 class="section_title">
      Latest Articles
    </h2>






    <ul class="summary_items">

        <li>




<article
  class="summary"
  data-type="article"
  data-article-type="news"
  data-premium="false"
  data-size="small"
>
    <a href="https://www.rockpapershotgun.com/dead-by-daylight-will-be-free-on-the-epic-games-store-next-week" class="link_overlay" title="Dead By Daylight will be free on the Epic Games Store next week" ></a>

    <span class="symbol"></span>
    


<div class="thumbnail">
  <img
    src="https://assets2.rockpapershotgun.com/dead-by-daylight-b.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/dead-by-daylight-b.jpg"
    srcset="https://assets2.rockpapershotgun.com/dead-by-daylight-b.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/dead-by-daylight-b.jpg 1x, https://assets2.rockpapershotgun.com/dead-by-daylight-b.jpg/BROK/thumbnail/550x310/format/jpg/quality/80/dead-by-daylight-b.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Murderous action in a Dead By Daylight screenshot."
width="275"height="155"  >
</div>

  <div class="wrapper">
        <div class="details">


          <p class="title">
<a href="https://www.rockpapershotgun.com/dead-by-daylight-will-be-free-on-the-epic-games-store-next-week" >  Dead By Daylight will be free on the Epic Games Store next week
</a>          </p>

            <p class="strapline">But this week, TheHunter: Call Of The Wild is free</p>
    </div>


    <div class="metadata">
    <span class="author">Alice O&#39;Connor</span>

    <time class="published_at" datetime="2021-11-25 20:07:42.312997+00:00">
        2 hours ago

    </time>

    </div>

    
  </div>
</article>        </li>

        <li>




<article
  class="summary"
  data-type="article"
  data-article-type="news"
  data-premium="false"
  data-size="small"
>
    <a href="https://www.rockpapershotgun.com/check-out-our-steam-autumn-sale-game-recommendations" class="link_overlay" title="Check out our Steam Autumn Sale game recommendations" ></a>

    <span class="symbol"></span>
    


<div class="thumbnail">
  <img
    src="https://assets2.rockpapershotgun.com/steam-autumn-sale_59rCxb1.png/BROK/thumbnail/275x155/format/jpg/quality/80/steam-autumn-sale_59rCxb1.png"
    srcset="https://assets2.rockpapershotgun.com/steam-autumn-sale_59rCxb1.png/BROK/thumbnail/275x155/format/jpg/quality/80/steam-autumn-sale_59rCxb1.png 1x, https://assets2.rockpapershotgun.com/steam-autumn-sale_59rCxb1.png/BROK/thumbnail/550x310/format/jpg/quality/80/steam-autumn-sale_59rCxb1.png 2x"
loading="lazy"    class="thumbnail_image"
    alt="Artwork promoting the Steam Autumn Sale."
width="275"height="155"  >
</div>

  <div class="wrapper">
        <div class="details">


          <p class="title">
<a href="https://www.rockpapershotgun.com/check-out-our-steam-autumn-sale-game-recommendations" >  Check out our Steam Autumn Sale game recommendations
</a>          </p>

            <p class="strapline">20 games, big and small, blockbusters and indies</p>
    </div>


    <div class="metadata">
    <span class="author">Alice O&#39;Connor</span>

    <time class="published_at" datetime="2021-11-25 18:40:54.469577+00:00">
        4 hours ago

    </time>

  <p class="comments">
      <a href="https://www.rockpapershotgun.com/check-out-our-steam-autumn-sale-game-recommendations#comments">
    5
      </a>
  </p>
    </div>

    
  </div>
</article>        </li>

        <li>




<article
  class="summary"
  data-type="article"
  data-article-type="deals"
  data-premium="false"
  data-size="small"
>
    <a href="https://www.rockpapershotgun.com/black-friday-2021-fnatic-streak65-mechanical-gaming-keyboard-down-to-83" class="link_overlay" title="The fantastic Fnatic Streak65 mechanical keyboard is just £83 for Black Friday" ></a>

    <span class="symbol"></span>
    


<div class="thumbnail">
  <img
    src="https://assets2.rockpapershotgun.com/fnatic-streak65-keyboard.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/fnatic-streak65-keyboard.jpg"
    srcset="https://assets2.rockpapershotgun.com/fnatic-streak65-keyboard.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/fnatic-streak65-keyboard.jpg 1x, https://assets2.rockpapershotgun.com/fnatic-streak65-keyboard.jpg/BROK/thumbnail/550x310/format/jpg/quality/80/fnatic-streak65-keyboard.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for The fantastic Fnatic Streak65 mechanical keyboard is just £83 for Black Friday"
width="275"height="155"  >
</div>

  <div class="wrapper">
        <div class="details">


          <p class="title">
<a href="https://www.rockpapershotgun.com/black-friday-2021-fnatic-streak65-mechanical-gaming-keyboard-down-to-83" >  The fantastic Fnatic Streak65 mechanical keyboard is just £83 for Black Friday
</a>          </p>

            <p class="strapline">Oooh, pretty</p>
    </div>


    <div class="metadata">
    <span class="author">Holly Alice</span>

    <time class="published_at" datetime="2021-11-25 17:21:00.360748+00:00">
        5 hours ago

    </time>

  <p class="comments">
      <a href="https://www.rockpapershotgun.com/black-friday-2021-fnatic-streak65-mechanical-gaming-keyboard-down-to-83#comments">
    2
      </a>
  </p>
    </div>

    
  </div>
</article>        </li>

        <li>




<article
  class="summary"
  data-type="article"
  data-article-type="news"
  data-premium="false"
  data-size="small"
>
    <a href="https://www.rockpapershotgun.com/warhammer-40000-chaos-gate-daemonhunters-details-its-toxic-villains" class="link_overlay" title="Warhammer 40,000: Chaos Gate - Daemonhunters details its toxic villains" ></a>

    <span class="symbol"></span>
    


<div class="thumbnail">
  <img
    src="https://assets2.rockpapershotgun.com/warhammer-40k-chaos-daemonhunter.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/warhammer-40k-chaos-daemonhunter.jpg"
    srcset="https://assets2.rockpapershotgun.com/warhammer-40k-chaos-daemonhunter.jpg/BROK/thumbnail/275x155/format/jpg/quality/80/warhammer-40k-chaos-daemonhunter.jpg 1x, https://assets2.rockpapershotgun.com/warhammer-40k-chaos-daemonhunter.jpg/BROK/thumbnail/550x310/format/jpg/quality/80/warhammer-40k-chaos-daemonhunter.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for Warhammer 40,000: Chaos Gate - Daemonhunters details its toxic villains"
width="275"height="155"  >
</div>

  <div class="wrapper">
        <div class="details">


          <p class="title">
<a href="https://www.rockpapershotgun.com/warhammer-40000-chaos-gate-daemonhunters-details-its-toxic-villains" >  Warhammer 40,000: Chaos Gate - Daemonhunters details its toxic villains
</a>          </p>

            <p class="strapline">Stinky Nurgle&#39;s plague will power up his minions</p>
    </div>


    <div class="metadata">
    <span class="author">Imogen Beckhelling</span>

    <time class="published_at" datetime="2021-11-25 16:47:07.405974+00:00">
        5 hours ago

    </time>

  <p class="comments">
      <a href="https://www.rockpapershotgun.com/warhammer-40000-chaos-gate-daemonhunters-details-its-toxic-villains#comments">
    2
      </a>
  </p>
    </div>

    
  </div>
</article>        </li>
    </ul>


  </section>



  <a
    href="https://store.reedpop.com/collections/rock-paper-shotgun"
    class="merch_component"
    target="_blank"
    rel="nofollow noopener"
    title="We&#39;ve been talking, and we think that you should wear clothes"
  >
    <div class="details">
      <img
        src="/static/014f0de91b9411059fdcbaf2e66634bd/img/placeholder-green.png"
        alt="Rock Paper Shotgun logo"
        width="150"
        height="50"
        loading="lazy"
      />
      <p class="title">We&#39;ve been talking, and we think that you should wear clothes</p>
      <p class="strapline">Total coincidence, but we sell some clothes</p>
      <button class="button">Buy RPS stuff here</button>
    </div>
    <div class="asset">
      <img
        src="/static/014f0de91b9411059fdcbaf2e66634bd/img/rockpapershotgun-shirt.png"
        alt="Rock Paper Shotgun Merch"
        width="180"
        height="160"
        loading="lazy"
      />
    </div>
  </a>

  <script>
    buttons = document.querySelectorAll('.merch_component');
    for (i = 0; i < buttons.length; i++) {
      buttons[i].addEventListener('click', function(e) {
        gtag('event', 'click', {
          'event_category': 'Store Component',
          'event_label': window.location.href
        });
      });
    }
  </script>

  <script>
    window.addEventListener('articleScripts', function() {
      new BrockmanTrackStacks({});
    });
  </script>

      </div>
  </div>
            </div>

        </main>

        <footer class="app_footer">
  <div class="nav_wrapper">
      <div class="about">


<a
  href="/"
  class="logo"
  
>
    <img src="https://assets2.rockpapershotgun.com/0275_rockpapershotgun-logo.svg" alt="Rock Paper Shotgun logo" loading="eager">
</a>
  <form class="search_box" action="/search">
    <input type="text" name="q" aria-label="Search" placeholder="Search">
  </form>

  <p>Copyright © 2021 Gamer Network Limited, a ReedPop company.</p>
  <p>All rights reserved. No part of this site or its content may be reproduced without the permission of the copyright holder.</p>


  <nav class="social_follow">
    <ul class="social_list">
          <li>
            <a
              href="https://www.facebook.com/rockpapershot"
              class="social_icon"
              data-type="facebook"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="facebook-f"
      data-type="brands"
        title="Check us out on Facebook"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://twitter.com/rockpapershot"
              class="social_icon"
              data-type="twitter"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="twitter"
      data-type="brands"
        title="Check us out on Twitter"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://www.instagram.com/rockpapershot"
              class="social_icon"
              data-type="instagram"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="instagram"
      data-type="brands"
        title="Check us out on Instagram"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://www.youtube.com/channel/UC5bKSAZBvV9AKlBJPG0Py-A"
              class="social_icon"
              data-type="youtube"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="youtube"
      data-type="brands"
        title="Check us out on YouTube"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://www.twitch.tv/rockpapershotgun"
              class="social_icon"
              data-type="twitch"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="twitch"
      data-type="brands"
        title="Check us out on Twitch"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://www.linkedin.com/company/rock-paper-shotgun-ltd"
              class="social_icon"
              data-type="linkedin"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="linkedin"
      data-type="brands"
        title="Check us out on LinkedIn"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="/feed"
              class="social_icon"
              data-type="rss"
              data-action="follow"
                rel="alternate noopener"
                type="application/rss+xml"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="rss"
      data-type="solid"
        title="Check out our RSS feed"
    ></span>


            </a>
          </li>
    </ul>
  </nav>
      </div>



  <nav class="nav_primary">
            <span class="label">Explore</span>


        <ul>
                  <li>
                    <a
                      href="/latest"
                      data-active="false"
                      
                    >
                        Latest
                    </a>
                  </li>
                  <li>
                    <a
                      href="/news"
                      data-active="false"
                      
                    >
                        News
                    </a>
                  </li>
                  <li>
                    <a
                      href="/reviews"
                      data-active="false"
                      
                    >
                        Reviews
                    </a>
                  </li>
                  <li>
                    <a
                      href="/hardware"
                      data-active="false"
                      
                    >
                        Hardware
                    </a>
                  </li>
                  <li>
                    <a
                      href="/features"
                      data-active="false"
                      
                    >
                        Features
                    </a>
                  </li>
                  <li>
                    <a
                      href="/videos"
                      data-active="false"
                      
                    >
                        Videos
                    </a>
                  </li>
                  <li>
                    <a
                      href="/guides"
                      data-active="false"
                      
                    >
                        Guides
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games?letter=a"
                      data-active="false"
                      
                    >
                        Games
                    </a>
                  </li>
        </ul>
  </nav>



  <nav class="nav_secondary">
            <span class="label">Popular Now</span>


        <ul>
                  <li>
                    <a
                      href="/topics/bestest-bests"
                      data-active="false"
                      
                    >
                        Bestest Bests
                    </a>
                  </li>
                  <li>
                    <a
                      href="/topics/free-games"
                      data-active="false"
                      
                    >
                        Free games
                    </a>
                  </li>
                  <li>
                    <a
                      href="/supporters"
                      data-active="false"
                      
                    >
                        Supporters
                    </a>
                  </li>
                  <li>
                    <a
                      href="/topics/black-friday"
                      data-active="false"
                      
                    >
                        Black Friday
                    </a>
                  </li>
                  <li>
                    <a
                      href="/podcasts"
                      data-active="false"
                      
                    >
                        Podcasts
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://discord.gg/rockpapershotgun"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Discord
                    </a>
                  </li>
        </ul>
  </nav>



  <nav class="nav_helpful">
            <span class="label">Helpful Links</span>


        <ul>
                    <li>
                    <a
                      href="/about"
                      data-active="false"
                      
                    >
                        About Us
                    </a>
                  </li>
                  <li>
                    <a
                      href="/authors"
                      data-active="false"
                      
                    >
                        Authors
                    </a>
                  </li>
                  <li>
                    <a
                      href="/code-of-conduct"
                      data-active="false"
                      
                    >
                        Code of Conduct
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://privacy.reedexpo.com/en-gb/cookie-policy.html"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Cookie Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="/editorial-policy"
                      data-active="false"
                      
                    >
                        Editorial Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://privacy.reedexpo.com/en-gb/ccpa.html"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Notice to California Residents
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://privacy.reedexpo.com/en-gb.html"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Privacy Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="/review-policy"
                      data-active="false"
                      
                    >
                        Review Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="/terms-and-conditions"
                      data-active="false"
                      
                    >
                        Terms &amp; Conditions
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/2021/11"
                      data-active="false"
                      
                    >
                        Archive
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.reedpop.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Corporate Site
                    </a>
                  </li>
                  <li>
                    <a
                      href="mailto:contact@rockpapershotgun.com"
                      data-active="false"
                      
                    >
                        Contact Us
                    </a>
                  </li>


      <li>
        <button class="optanon-show-settings">
          Cookie Settings
        </button>
      </li>
        </ul>
  </nav>

  

  <nav class="nav_sites">
            <span class="label">ReedPop</span>


        <ul>
                  <li>
                    <a
                      href="https://www.cosplaycentral.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Cosplay Central
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.dicebreaker.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Dicebreaker
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.eurogamer.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Eurogamer
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.gamesindustry.biz"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        GamesIndustry.biz
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.jelly.deals"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Jelly Deals
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.metabomb.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Metabomb
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.nintendolife.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Nintendo Life
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.pushsquare.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Push Square
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.thehaul.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        The Haul
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.usgamer.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        USgamer
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.vg247.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        VG247
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.videogameschronicle.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        VGC
                    </a>
                  </li>
        </ul>
  </nav>




  <nav class="nav_events">
            <span class="label">Events</span>


        <ul>
                  <li>
                    <a
                      href="https://www.egx.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        EGX
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.mcmcomiccon.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        MCM Comic Con
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.paxsite.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        PAX
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.starwarscelebration.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Star Wars Celebration
                    </a>
                  </li>
        </ul>
  </nav>
  </div>
        </footer>
    </div>
  </body>
</html>