View Full Version : TF2 issues

19-08-2011, 01:49 AM
Sorry, I figure here might be better then Steam Forums.

My TF2 doesn't work. I do not know why it does not work, but it freezes on start up, or it attempts to validate the cache, gets to 100% and hangs. Never validates, never allows me to run the game. I've attempted defragging it, reinstalling steam, reinstalling TF2, reinstalling TF2 and Steam...

I'm at a loss - and I quite enjoy TF2, so I'd really be very happy if I could play it anytime I wanted.

[Small side note. It will play fine after a TF2 update.]

19-08-2011, 03:47 AM
Have you tried running it with all graphic settings at minimal, regardless of your PC's specs ? Just to test functionality.

19-08-2011, 09:56 AM
Have you tried all the obvious stuff?
Updated DirectX, graphics card drivers etc? Doesn't sound directly related, but is always worth a try.

20-08-2011, 11:49 AM
I've done all of the above. I hadn't updated graphics card drivers, but I just checked and I don't have any new ones to pick up.

I can't run it on the lowest setting, because when it won't run, it won't load up. Becomes unresponsive on the valve screen, and I have to quit it via the task manager.

I did manage to play for a few hours the other night, and it ran fine on the normal graphics settings, just after the game updated to put the Human Revolution items in, but now it doesn't work again. It's really quite irritating, as I'm quite a fan of Team Fortress.

22-08-2011, 10:10 AM
Well, no idea then. The only thing I could guess would be a problem with the hard disk (defect sectors or something). That could be an explanation that it worked after Steam updated the game. Or a virus/malware.
But that's only wild guessing (obviously).

22-08-2011, 01:06 PM
I got this issue last week.

When I had this issue last week the TF2 forums over on Steam were full of people crashing in just the same way - the loading screen would appear, and the game would just not respond.

I just stopped playing, hoping for a patch, but haven't tried since.

Basically, you are not alone, and hopefully Valve will patch this problem out.

In the mean time, the usual defrag / verify options may help.

23-08-2011, 07:07 PM
Have you had any issues with any other programs not functioning correctly? One of my work machines got this weird bug where some executables were blocked or broken by this pesky root kit. It was a real pain to get rid of. If other games all work fine, and no other programs have issues, then I'm clueless.

27-08-2011, 05:16 AM
When you go to verify steam cache, and it looks like it is stuck at 100%, don't stop it. Let it run an hour or more, just go have dinner or movie or sleep etc...