View Full Version : Steam melting my CPU

23-09-2011, 07:12 PM
Since the latest update, Steam seems inclined to use an entire core out of the two my system has available.

Anyone else seeing this?

23-09-2011, 07:17 PM
No. Is it always like that? Might need a reinstall.

23-09-2011, 07:35 PM
Is this when playing games or just with Steam running in the background?

The Tupper
23-09-2011, 08:05 PM
Steam was doing precisely that with my machine (a somewhat elderly 2.4Ghz Core 2 Duo) from about June this year until recently and I was tearing my hair out. I never quite got to the bottom of it, but it seemed that it might be related to a Team Fortress 2 file corruption. Might.

I fixed it by completely removing Steam (and - importantly - all the game application data too, I'm afraid) and then re-installing steam and any games you need. It's a hefty task to re-download all your games, I know, but it worked for me. Oh - one other thing: as a precaution I would suggest naming your new install directory something like 'Steam 2' to make sure that there's no registry legacy stuff likely to screw it up. That's what I was told by someone who knows, anyhow. Not an expert myself. Any good?

23-09-2011, 08:45 PM
Just copy steamapps folder somewhere else and then reinstall Steam. After that, copy it back to its place. Note: You need to restart any game trough Steam itself if you reinstalled Steam somewhere else other then the old installation location.

The Tupper
23-09-2011, 09:01 PM
Re. Draakon: I did the same (and variations) and it still didn't work. It was only when I deleted everything that it worked properly.

23-09-2011, 11:13 PM
Strange, mine did. Did you try launching the game once when you copied back (both trough steam and from the gamefolder)?

24-09-2011, 10:46 AM
Fiddling about with this gives pretty similar results to The Tupper's.. Moving all the steamapps files to a safe place and reinstalling Steam led to a reasonable amount of cpu load. Moving the files back in place returned it to overload. I guess something in there has become wedged..

24-09-2011, 12:25 PM
I had this yesterday, but simply closing steam and reopening it cured the problem for the rest of the day. It's not misbehaving (so far) today, either, so maybe just a "first run" thing?

24-09-2011, 12:34 PM
The misbehaviour persisted between restarts of Steam for me.

I seem to have resolved it by deleting all the *cf files under steamapps. When I go to redownload stuff, it picks up the files that are already on disk.

24-09-2011, 12:55 PM
I was having a similar problem to Harlander, and I seem to have resolved it by just removing the files pertaining to source engine games (including might and magic, alien swarm, portal, etc). I was able to leave other files and folders, including g(/n)cfs for other games just fine.

Didn't even have to reinstall the thing. I suspect it got caught in a cycle of trying to update something, somehow.

24-09-2011, 10:42 PM
I also had the high CPU load issue today. I had to restart steam three times until it stopped.
A few times since the update I also had an error message saying something like: you have never started steam from that machine etc.

The Tupper
25-09-2011, 11:45 AM
Glad you got it sorted. I spent a couple of months changing processor affinities and setting priorities every time I wanted to play Batman AA before biting the bullet and deleting everything. It's made me realise how little I play so many of the games I have on steam: I've only re-downloaded three in the last three weeks.

25-09-2011, 09:55 PM
I'm having a problem starting Human Revolution after the update, with it sticking at 'installing... 2%'. :(

26-09-2011, 04:36 PM
I'm having a problem starting Human Revolution after the update, with it sticking at 'installing... 2%'. :(

Have you tried verifying the game cache (right click-> properties-> local files)?

26-09-2011, 05:06 PM
This is a problem with the latest Steam client. There's a fix for it in the current beta.

28-09-2011, 02:41 AM
I was having that problem too. Looks like the beta went live today, and after updating and restarting it's barely using any CPU.

28-09-2011, 06:55 AM
You could also next time If you indeed want to have steam open (like I did recently, was downloading DSF from steam) do like me. My CPU useage was also high due to me downloading a game and since I have a very fast Internet connection, it ate a lot of CPU. I then decided to put priority on very low for steam. And VOILA! Steam was only using 99% of my CPU when the whole computer was on idle. Else, the usage dropped down as other, higher priority applications needed to use the CPU.