View Full Version : Cd-Rom drive & USB not working properly

27-06-2012, 11:55 AM
I want to ask you if you would know what reasons are there,for mother's CD-Rom drive not to read any cd's. She have laptop and yesterday we didn't had internet so she wanted to watch some movies and i tried putting some dvd's in and nada,but those were not original,so i tried with Deus Ex 1 game and it read it,then i tried with stranglehold and nothing again.. What could it be wrong ?

And for USB,i have kingston 16 GB usb which always worked but now when i try to use it i get message

"You need to format disk N before you can use it. Do you want to format it ?" So i click format disk and i get WINDOWS CAN?T FORMAT DISK... :(

So usb its not working now.

27-06-2012, 03:19 PM
Are you sure it's actually a DVD drive? If it's a really old laptop, it might not be. That would explain why it read DX 1 but not a DVD. Not sure about the USB key. Again, if it's an old laptop with an old OS, it might not be able to pick up the driver for it automatically. Try plugging in a USB keyboard or mouse and see what it does with those.

27-06-2012, 05:25 PM
Well its not an old laptop,she bought it two years ago.

Hardware is Pentium Dual Core 2.0,integrated GPU,4GB of ram and 500GB disk,also Os is Windows 7 64x and on DVD Drive is writen DVD :x

27-06-2012, 05:54 PM
DVDs and CDs are read with a different laser, so it's possible for a drive to stop reading DVDs but continue to read CDs without issue. I had a DVD player that stopped reading DVDs but continued to play music CDs just fine.

I would try

1) a disc-cleaner
2) replace it with a drive from another laptop. Nearly all of them are fixed in place with 2-3 screws and use a standard connector, so if you had another you could try that one in it.

As for the USB drive, sounds broken. Maybe try running chkdsk on it but I'd say it's boned

27-06-2012, 08:23 PM
I had similar error messages on USB sticks when I used to unplug them without properly unmounting them first. Could that be your problem? Do other USB drives not work or is it just this one?