View Full Version : P2 install problems

07-10-2012, 12:02 PM
Hey folks

After about 38% installation on Planetside 2, I get the following error:

*Error: Unable to write to C:/Program Files (x86)/P2 BETA/Resources/Assets/Assets_091.pack - http://pls.patch.station.sony.com/patch/sha/code4344/code4344.sha.zs/f3/16e/5f795409ac4716af096775faae04dbf7f50. The file may be in use or you may lack the necessary permissions to install.

Anyone else experienced this?

07-10-2012, 12:14 PM
Nevermind, it seems that running Launchpad as administrator solved the problem. Doesn' t make sense to me at all since it could install the first 38% in normal mode, but, hey... problem solved.

09-10-2012, 06:19 AM
We have an eclipse feature that is licensed and the license is handled by our own code. The user can go in on our update-site and upgrade his feature. The problem we face is when the user's license needs to be updated before he can use the new upgrade.

What I want to do is to validate the feature version against the users license and warn the user that his license needs to be updated before he install.

I thought I would do this using a custom eclipse p2 touchPoint action validateLicense

My code is called, where I validate the version against the user's license. If it fails I warn the user and he can then cancel the installation.

So my first question is:
Do I get this right, or is it some other way to do this?


dainik bhasker (http://www.deshmeaaj.com)