View Full Version : Big uh oh in BOOTMGR town

27-10-2012, 10:50 PM
Evening all,

So I've got a problem with my PC and I can't work it out. Earlier on I'd just exited Borderlands 2 and left my PC idling while I went to get dinner, as I have done every night for basically my entire life and I'm sure you all do it too, right? I came back and my monitor was just black, but the power was on and no 'check cable' message was up. I tried to ctrl-alt-del it away after I saw that alt-tabbing and general mousing around wasn't doing anything, but nothing happened. I left it for a while and it became apparent that it was just dead, so I hard reset it. When the BIOS was loading I noticed it was only picking up my 2TB D: drive, no DVD nor SSD boot drive, and then I got a message about not having any bootable media and such.

So I turned it off, unplugged all of the drives except for my SSD, turned it back on and the SSD was being picked up again. This time, after the BIOS screens it said 'BOOTMGR is missing', or words to that effect. This made me sad. I opened up my PC properly, unplugged all SATA connectors, re-seated all connections and turned it back on. Bingo, it booted. Satisfied that the problem was just a loose connection, I resumed Borderlands 2.

After about, I don't know, half an hour or so I tried to quit the game again, at which point my system went and locked up again. The screen froze this time, didn't turn black, and the game's music was playing in the background. I ctrl-alt-del'd to get it to respond, the screen went black, the music continued... Nothing. I left it, came back and it was still not responding. Hard reset again, BOOTMGR message again. Opened up the PC, unplugged the SSD's power, plugged it back in, swapped SATA connector with my 2TB drive and now it has booted again.

Now, I would have thought if it was the SSD ageing (I bought it last November) or corrupt files, it would just be dead, kaput, an ex-drive, but it has recovered from the 'BOOTMGR' message twice now. Could it be the drive controller, maybe? But this is an ASUS Z68-V Pro (also bought last November)! Surely they're not as flimsy as that? Perhaps it's the SATA cable, which begs the question: Do I leave the cables swapped and use the cable that could have been causing a problem to connect my 2TB drive and get on with it, which could potentially lead to corrupt data on my drive which holds everything (I consider my SSD to be pretty much expendable as there's nothing more than saves and the OS on there), or do I swap them back and wait for this to happen again? I do have a spare SATA cable so maybe I'll use that, and I do also have a second drive controller on the board so I could move the drives over to that. I wonder if that'll cause any problems in itself, though?

TL, DR: SSD appears to be dying, got 'BOOTMGR missing' twice, managed to get it to boot again after unplugging and replugging. Surely a dead SSD just wouldn't recover like that?

Any thoughts or suggestions would be appreciated, cheers.

27-10-2012, 11:15 PM
I doubt the SSD is screwed (unless you've been defragging repeatedly which you shouldn't do) so it might well be a case of the machine/GPU overheating or some such? Maybe give the case a thorough clean out (remove everything, dust it all off and then replace). See if that sorts it out. Recently I was playing XCOM and I noticed my rig internal lights were glowing red (never a good sign) and it was down to one of the fans having stopped working.

28-10-2012, 12:13 AM
Well, I suppose it might be a faulty SATA cable. You'll know once the problem recurs or if it hasn't after a few weeks. In which case the solution is thankfully simple and cheap.

Standard annoying question: Do you have the latest drivers installed for your motherboard chipset and SATA controller? It would be odd for problems to pop up this way due to driver problems, but then again outdated/missing motherboard drivers are pretty good at causing odd problems.

28-10-2012, 12:23 AM
Thanks, I'll give that a shot but I'd be astonished if it's down to overheating because all my fans are running, my graphics card's fans were barely audible (meaning they had sped up but it wasn't getting overly hot) and switching the computer off and trying again doesn't work, I have to fiddle with the SATA cables and then it works. For a while.

I was just playing again, same game, and it froze after about an hour. This time I didn't try anything, I was just running around and the image froze but the sound didn't. I tried to ctrl-alt-del again, screen went black, music continued but this time I could move and see the cursor. Hard reset, SSD not detected but other drives were, BOOTMGR missing. Tomorrow I'll take my graphics card out, dust a little (assuming PC World sells compressed air) and switch the drives to the other controller. If that doesn't work I'll use my spare SATA cable and if that doesn't work I'll cry and fork out for another SSD. I want one for my Mac eventually anyway so if it turns out to be something else I'll just stick it in there.

Does this sound like a plan or a fool's errand?

Edit: as for motherboard drivers, I haven't touched them since November... Wouldn't the problem have surfaced before now if it was that? I haven't even updated the BIOS, about the only thing I do do is update my graphics drivers. I'm a bad man.

28-10-2012, 10:55 AM
Ok so this is what I've done so far:
Changed the SATA cable
Plugged the SSD into a different port on the same controller.

This hasn't fixed the problem but I have discovered what the BOOTMGR message is about.

Basically, what seems to happen is the SSD becomes disconnected which, understandably, causes a crash. It isn't re-detected and the BIOS selects the next drive to boot from, my 2TB drive, which has no OS installed so I get the BOOTMGR message. If I open the PC, unplug the SATA connector then plug it in again, reboot and open the BIOS settings, tell it to boot from the SSD then it's fine.

I timed it just now and it lasted 56 minutes, 9 seconds before freezing. This time, Borderlands 2 froze for about 10 seconds, came back for maybe 2 seconds then quit itself. Chrome responded for a brief period before quitting (I clicked the RPS bookmark, the address bar changed to www.rockpapershotgun.com (http://www.rockpapershotgun.com) but then it closed), Microsoft Security Essentials had a message pop up saying the process had stopped and the iTunes helper said an I/O error had occurred, click here to exit the program. When I clicked the screen went black, the cursor remained (which I could control), then I just hard resetted, turned off the PC before it attempted to boot, opened it, unplugged the SATA connector, plugged it back in and powered it on again and it booted fine.

So it wasn't the cable and I don't think it's the drive controller, but it seems like a physical problem with the SATA connection. If it's the SSD dying then I have no idea why it boots every time as long as I fiddle with the connection first.

28-10-2012, 11:16 AM
Have you tried plugging the SSD into a different controller on the motherboard? I have 2 SATA 6gb controllers on my motherboard, and a quick look at the specs of yours shows the same (2 navy blue and 2 grey ports).

28-10-2012, 11:45 AM
I haven't tried that yet (because my graphics card makes it a real bitch to reach the other controller), but it's the next thing I'm going to try. It just seems odd that after a crash the SSD doesn't show when I reset but the 2TB and DVD drives do. I spoke to my Dad who used to design computers (as in literally) back in the 70's and he seems to think it's a cache flush problem because of the fact that it happens after a certain amount of time, he reckons the SSD isn't clearing some sort of cache so when it overruns it just shuts down, but that doesn't explain why unplugging the data connection fixes the problem. If the other controller doesn't fix it then I guess I have to accept the SSD is dead!

28-10-2012, 11:02 PM
A similar thing was happening with my OCZ vertex 2 drive - in the end, I pulled the files and got a new Samsung one - the drive was barely a year old, and I'd forced a hard shutdown (held the button down) during the shutdown screen (because, you know, it wasn't shutting down). After this point, the drive intermittently worked, and I managed to retrieve critical files before sending it back to OCZ. I have a replacement that I haven't bothered to open - its not worth the trouble.

At any rate, it could be a controller problem? try updating the firmware on it if you can. That apparently can fix poor controller issues, but if the drive if frequently... not responding, I'd say thats a bad sign.

29-10-2012, 02:50 PM
What kind of SSD is it? If there's a firmware update for it, I'd start there. Then motherboard firmware (for the SATA controller updates), and then SATA drivers (Intel RST). Stick to the Intel SATA controller ports if you can.

My guess is that this is a flavor of the ambiguous SATA power spec issue from roughly a year ago. It would cause SSDs in sleep mode to not wake up (and thus also be missing after a reboot, but return once the power had been fully off). OCZ Vertex 3's suffered from this and would randomly BSOD and then go missing. Nobody admitted any fault, and the issue was quietly patched around with new SATA controller and SSD firmwares.

31-10-2012, 01:31 PM
Sorry, I always forget to actually keep up to date on forums and such. It's a Crucial M4 128GB, and I'm convinced the fault is with the drive because I replaced it with an old Deskstar with XP SP3 on it and it's running flawlessly, so it's not likely to be a driver error (as there are no motherboard drivers installed) nor the disk controller. I've just seen that there is a firmware update from September so I'll give that a shot. Here's the changelist:

Version 010G includes the following changes:

Improved Trim response time
Improved power-on-to-ready time (known as POR, or TTR for Time-to-ready)
Improved resume-time from low power modes, and improved reliability of warm reboot
Improved power consumption by disabling HIPM (Host Initiated Power Management)

Those last two sound relevant, but it's an odd coincidence. I would've thought if it was a problem with firmware I would have had issues the entire time as nothing in my PC's hardware or software (apart from Nvidia drivers) has changed since May.

01-11-2012, 04:30 PM
It's probably no coincidence. SSDs have very aggressively timed power-saving modes, which is why the SATA controller update could help workaround known issues, and why you wouldn't any problems with HDDs on the same setup. Try the new M4 firmware and if that doesn't help contact Crucial support for an RMA, as bad devices do happen sometimes. There was also a bug in the M4 firmware (http://hothardware.com/News/Crucial-Acknowledges-Weird-5000-Hour-M4-SSD-Bug-Promises-Firmware-Fix-in-MidJanuary/) that triggers after 5200 hours of total use (7.12 months).

10-11-2012, 03:23 PM
It's probably no coincidence. SSDs have very aggressively timed power-saving modes, which is why the SATA controller update could help workaround known issues, and why you wouldn't any problems with HDDs on the same setup. Try the new M4 firmware and if that doesn't help contact Crucial support for an RMA, as bad devices do happen sometimes. There was also a bug in the M4 firmware (http://hothardware.com/News/Crucial-Acknowledges-Weird-5000-Hour-M4-SSD-Bug-Promises-Firmware-Fix-in-MidJanuary/) that triggers after 5200 hours of total use (7.12 months).

Very interesting... Well, I just tried to update the firmware and first of all got a blue screen before I even did anything, and then after a reboot and managing to start the firmware update it said there was an error with the update. I'm currently typing from the system on the SSD so it does still turn on, but the device manager says the firmware is 010G (the firmware updater itself said 009 beforehand). I'll just leave the PC running for a while and see what happens when I come back. It would be great if this has worked, after 260 hours of Borderlands 2 I'm getting a craving for DCS World (don't ask why because I couldn't tell you) which won't run on my 32-bit XP system.

Oh, and thanks for your help everyone!

Update: Bobtree, I don't want to speak too soon but I think you nailed it. Since updating the BIOS at 1520, it's now 1730 and there hasn't been a crash, previously it would happen within an hour without fail... Touch wood (well, MDF) and all but I'd say this is fixed, thank you incredibly very much!

10-11-2012, 07:47 PM
Firmware update errors might be cause for concern, but if isn't currently broken then don't fix it.

FWIW, when my finicky SSD was throwing BSODs, they were often a week or two apart.

10-11-2012, 11:01 PM
Indeed, I'm happy to let it go until something happens again. Weird thing is the BSOD (my first ever in my life, by the way) happened between agreeing to the license, er, agreement and clicking 'start', I hadn't done anything and it threw a fit. After rebooting I was quicker to click 'start' and then it returned an error, yet the firmware is showing as having been updated and there hasn't been a single crash or wobbly moment since.

I guess I'll get round to working out how to back up my saves with Dropbox and then the SSD can do what it likes, I feel like I stared death in the face and realised it's actually not going to be all that bad when the SSD does finally die... I'll be alright as long as it doesn't physically explode and take my 2TB drive with it! Thanks again, serious amounts of appreciation going on around here.

11-11-2012, 12:15 AM
My "PC Tech Radar" tells me something in your PC is overheating - and not necessarily the usual suspects of CPU or GPU.

Power Supplies can, and do, overheat - and when they do, weird shit happens (graphical freezes/system freezes/drives not spinning up etc. etc.)

Other components can overheat too - tho it's unusual to see a mobo component to overheat without the CPU running fairly hot too - but heatsinks/heatpipes detach or loosen.

I'd certainly be cleaning the PC out, checking all the temps (before and after) and considering a new PSU, even as a backstop because you'll need it sooner or later.

Remember, a PSU failing can take other components with it - so it's really one of the first things you consider changing to eliminate this stuff...