View Full Version : Installation Problems

08-08-2011, 11:51 AM
Sorry to post another problem, but I thought you guys could possibly help.

I've had trouble installing games recently, both digitally and retail. Fallout 3 throws up CRC errors on various files, and both Borderlands and GTA IV (All three retail) threw up similar issues. Digitally The Longest Journey and Majesty 2 Collection have given their same issues. Heck, even iOS 4.3.5 won't download as it comes up with a corruption error. Effectively the CRC (And similar) issues are about corrupt files during set up, and as such I can't proceed with installation.

I ran a chkdsk on my Hitachi DeathStar, and it said I had some errors but "0kb in Bad Sectors". I rebooted into a chkdsk /f, and it didn't seem to make much of a difference.

I'm guessing that my HDD is practically dying, then? My games are slowly starting to crash more and throw up errors, and Firefox is crashing a few times a day, I reckon.

08-08-2011, 12:13 PM
Sounds like the Hard disk, yeah.
You should try the Hitachi tools for HDD diagnosis (http://www.hitachigst.com/support/downloads/#OGT).

08-08-2011, 12:35 PM
Sounds like the Hard disk, yeah.
You should try the Hitachi tools for HDD diagnosis (http://www.hitachigst.com/support/downloads/#OGT).
... Drat! I could have tried that. I actually threw my hands up after posting this topic and started to install my OS on 500GB something Blue Something. Western Digital, I think.

08-08-2011, 03:37 PM
And that didn't happen because it decided it didn't like my copy of XP, and it refused to activate. Windows 7 should be here tomorrow, however. I needed to get onto 7 as it was (Just to stay somewhat relevant, plus I half-want Just Cause 2), and I doubt my HDD would be able to be fixed, so yeah...

Thanks for the assistance, though.

08-08-2011, 05:50 PM
Yikes. Quite a pickle you've got there. It seems like you've moved on from the original hard-drive onto bigger and better things, but I just wanted to add that chkdsk /r will attempt to repair sectors on the disk. However, it takes a looooong time depending on the drive's capacity. And at this point, you're probably better off with moving to a new drive. Good luck!

09-08-2011, 09:07 AM
Without warranty and the current HDD prices it would be pretty pointless to repair the drive.
Concerning the XP: I assume its an original so you can call a free hotline (from Microsoft) to activate it. What you say can happen if you have activated Win XP too often with different hardware setups. After that you always have to activate it over the phone.
But anyway, Win7 it is.

09-08-2011, 09:31 AM
I rang the number it gave, and put in the code it gave me, but it didn't like my other copy, and I didn't have the code for this one. Ah well. I needed to move on to 7 and 64bit anyway, just to make the most of my 4GB of RAM and my GTS 450.

09-08-2011, 07:46 PM
Frakkity frak frak frak.

I got a CRC error installing W7, but I formatted the drive after, tried again and it worked fine, so crisis semi-averted. Then, brilliantly, I got one installing The Longest Journey (Fixed by cancelling the installer and running the setup again), and the same again for Dreamfall, both from discs. I tried downloading the new iOS for my beloved iPod Touch 4G, but I got the network error again, but my network connection did seem to actually die right then. Tried to wiggle my adapter about, and... it snapped off.

I've ordered another new DVD drive (SATA this time) and a new wireless adapter (PCI rather than USB). So, in the course of two days, that's 140 I didn't want to spend, and it just cost me 10.50 delivery for my drive and adapter in order for them to come tomorrow.

On the plus side, Windows 7 is kinda funky.

10-08-2011, 11:34 AM
Fallout 3 threw the error up a few times during installation, but if I keep retrying it seems to eventually work. I've downloaded the Western Digital diagnostic tools, though, so I'll run them.

These errors aren't making sense, though. This is the third disc drive I've tried and I get errors, this is the second HDD... Sigh :(

10-08-2011, 04:38 PM
Is you connection SATA or IDE? In either case, try replacing the cable, and plugging it into another port.

If a new HDD and a new optical drive are giving you the same errors, it might be time to consider your mobo may be crapping out on you. :(

10-08-2011, 06:57 PM
SATA. I'll try the cable/port thingy though, good call on that one.

What's odd is that Drakensang: The River of Time and Sacred 2, along with my FO3 GotY DLC disc, installed fine, but neither of my GTA IV games (Standard and EfLC), Fable 3 nor King's Bounty: Crossworlds installed error free (If at all). I tried the copy-to-HDD trick for KB:C, but it just CRC'd on a different file.

This sucks majorly :(

10-08-2011, 09:32 PM
The fact that you can install some stuff and not others is probably of little relevance - it likely means whatever is wrong, it's a malfunction that causes random / intermittent loss instead of a total component shutdown - in fact a more definite problem would be great because the cause would be pinpointed much more effectively.

Well, I'm assuming you ran a memcheck. While ram works in mysterious ways and a memcheck is by no means definitive, and that kind of error is very unlikely caused by ram corruption... I just like to always keep ram on the table because ram is a fickle mistress and will every now and then be the cause of oddball problems.

If you've tried 3 disc drives, then that makes it highly unlikely it is a disc drive problem; same with HDD - though I would try a third HDD, just to be sure it's not a freak coincidence.

This leaves the connections between mobo and drives, and the mobo itself, as places where data can corrupt. I'm guessing it's the cables, but it might be a bad sata port on the board, too. Also, keep in mind that sata ports might share lanes on the motherboard, so don't connect the new cable to the one beside, if you have several try the ones farthest apart from the current ones.

10-08-2011, 10:13 PM
Some good tips there, Ash, I'll give some a go tomorrow. I'll confess I've not done a memcheck, but I certainly will.

I tried turning DMA off on my DVD drive, but it seems to have done little. I found both my Spellforce games installed fine, and Gray Matter, Venetica and Drakensang (The first) did if I kept moving the disc around. It doesn't work for every game, but for those three turning the disc slightly worked for a short period of time. Very odd.

I also changed my SATA cable, but I plugged it into new port too, but that's also done nothing. I'll try it on another one as well, just to be sure. I have 6 or 8, so I'm spoilt for choice ;)

11-08-2011, 10:19 AM
How odd. I ran a memtest, and one of my sticks had 1000+ errors before it was halfway done. I stopped, turned my PC off, removed the one closest to me and bam! I had no errors after a short run of memtest afterwards. I booted up as normal, put King's Bounty: Crossworlds in and it installed! Well, it took three quarters of an hour, but it installed!

So now to work out why my PC is running so damned slow.

11-08-2011, 10:24 AM
Ah, good old ram. It's like religion. It seems unlikely that problems happen due to ram, but you can never truly disprove it.

I'd say your PC is damn slow because it's running with half the ram? Kinda hard to know without your system specs. But if you were running in double-channel before and simply removed one stick, chances are the bios is still setup to run in double channel.

11-08-2011, 10:33 AM
Sorry, I'm running on 3GB now.

My specs are now:
Q8300 @ 2.5GHz
GTS 450 1GB
500GB Western Digital Caviar Blue

I'll poke the BIOS later.

Edit: I turned DMA back on for my DVD drive, and my installation sped up, so maybe that was it.

11-08-2011, 04:37 PM
Great, seems like you're mostly done, then?

Keep in mind that modern ram usually is made to work in pairs. So if you 3G are 3x1G, that could be causing performance issues as well. And even if it's 1x2G and 1x1G...

Bottom line, different ram from different manufacturers supports different placement configurations - the safe bet is to set up ram in pairs, same-sized modules.

11-08-2011, 05:09 PM
It seems to be running completely fine now. Well, almost. Installations are fine, GTA IV is installed and running, etc.

I just got hit with a Memory Management BSOD in The Settlers 7, however, after some texture flickering. This'll be fun to sort out. I did read that it could be a graphics driver problem, and they're simple enough to sort out most of the time.

My original 2GB of RAM is a pair, I believe, and they've been fine for about 4-5 years now. When I get some more RAM, I'll either go for 2x1GB or just replace what I have wih 2x2GB.

11-08-2011, 05:20 PM
Considering the kind of games you are playing, it's probably worth getting a fast, reliable 2x2 for optimal performance.

11-08-2011, 06:35 PM
Just been on my usual supplier's site. Wowzer, their DDR3 is dirt cheap. :D

I'll keep that in mind. Thanks for all the assistance, Ash. It's much appreciated.

11-08-2011, 06:57 PM
Indeed, DDR3 is quite affordable, and while I'm not sure if going from 4 to 8 gigs has a decent impact on current games, it's smart to save two slots on the mobo for that upgrade, if you can.

Mind you, ram is a component where you don't want to go for cheap - get a decent brand and double-check your motherboard and cpu ram compatibility tables on their vendor's sites. It might seem excessive work but it could save you headaches and a RMA.

You're welcome. :)

11-08-2011, 07:02 PM
My motherboard is weird. It's got 4 x DDR2 slots, and 2 x DDR3. I've opted for 2 x 2GB DDR3, and I'll take the DDR2 out.

I went for Kingston CL7 stuff. It was less than 10 for 2GB, which is a bargain.

17-08-2011, 10:40 AM
Right, my new memory finally arrived today (I paid economy and it shipped 'next day'. Huh), and my system feels a little snappier as I've got 4GB in 2x2GB and dual channel. Yay!

Anno 1404 is still CRCing, but it could be a dodgy disc as everything else seems to be fine now.

17-08-2011, 11:37 AM
Keep in mind that modern ram usually is made to work in pairs. So if you 3G are 3x1G, that could be causing performance issues as well. And even if it's 1x2G and 1x1G...

Dual channel was originally designed to counter the fact that a CPU's front side bus speed was so much faster than the RAM speed. As RAM speed increased while the FSB didn't, that kind of became irrelevant.

Now, modern processors and chipsets don't actually use the FSB to communicate with the RAM. They use something different the name of which escapes me right now (and I think it's different for AMD or Intel). It's certainly a lot faster than FSB, but because it works differently, I haven't been able to get a clear answer on whether or not dual channel makes much of a difference with that.

17-08-2011, 11:51 AM
It's certainly a lot faster than FSB, but because it works differently, I haven't been able to get a clear answer on whether or not dual channel makes much of a difference with that.

The last time I read something about that it was marginally, 1-3%.
AMD: HyperTransport
Intel: QuickPath Interconnect