Results 1 to 3 of 3
  1. #1
    Obscure Node
    Join Date
    Sep 2011

    Witcher 2 does not start

    So! I just bought (via steam) The Witcher 2, in anticipation of the 2.2. patch. I downloaded and patched it pre-2.2. and encountered a problem, which still persists after patchin to 2.2.: the game does not start, at all.
    Before 2.2. all it did was pop up the usual small box from steam which said "Preparing first time launch", which it already had said before patching and installing the directx thingys and so. The box stayed for like half a second and then it disappeared, but the game didn't launch.
    I was optimistic (which I should have not been) that the patch will fix this. Just now patched it and attempted to start. The box says "Preparing to launch The Witcher 2" again for a 0.5sec and then nothing.

    I tried some weird solution of deleting content, downloading again, then turning off anti-virus and steam, restarting steam as admistration, installing and patching and starting from the executable as admistration. Some said that the solution work, but for me it did nothing. Also tried doing a new account in windows, and starting the game from there. Some said that also worked, but again it did nothing.

    I'm running win7 64bit, 560 ti and i5 2500k.

    Hope someone has some answers!

  2. #2
    Activated Node JiminyJickers's Avatar
    Join Date
    Jun 2011
    New Zealand
    Are you letting steam patch the game or are you attempting to manually patch it?

    If you are manually patching it, then you will most assuredly break it. Let steam do the update. Apart from that I have no suggestions.

    I'm running the gog version.

  3. #3
    Lesser Hivemind Node DigitalSignalX's Avatar
    Join Date
    Jun 2011
    USA, Missouri.
    I'm running GoG version as well, and I chose not to install 2.2 - you can either launch from the main exe or skip it in the launcher. If it's your first time playing TW2, then the patch is probably advised. I presume you've updated all your audio/graphic drivers and meet the minimum spec?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts